CSV encryption not working

I have a super basic flow that comes in as an Excel file, adds a few columns via the constant value column node and the column expressions node and then reorders them via the column resorter.

I’d like to export via the CSV Writer, but it is not writing any Japanese or Chinese characters. All I get is junk characters. I tried the different encryption options, but they’re all coming back with junk characters. The different encryption options replace the Japanese and Chinese characters with different junk characters: Some simply replace them with questions marks; others replace them with wingdings. But none of the encryption options are preserving the Japanese and Chinese characters. (I’m guessing this would affect other alphabets, too, but my files only have the western alphabet, Japanese and Chinese.)

I’ve searched on the forums for help, and everything I’ve seen recommended changing encryption, which isn’t working. Anything else I should try?

I’m using KNIME 4.5.2. The only type of node I have in this flow that’s not in the base install is the Column Expressions node from the KNIME Labs extension.

@Data1981 welcome to the KNIME forum. So have you tried to use UTF-8 or UTF-16 encodings (Unpivotion:Chinese is not supported - #2 by mlauber71)?

On my system it seems to work.


Thanks. I figured it out. It appears to be an Excel problem not a KNIME problem. Excel isn’t automatically recognizing it as UTF-8 just by double clicking to open or opening with File>open. Instead, I have to open the CSV into an Excel file via the “From Text/CSV” option in Excel’s data tab. Excel automatically recognizes the UTF-8 when I do that. Maybe there’s something I could do to make Excel automatically recognize it when open a CSV straight from file explorer. But I’m not too worried about it since I’m only using Excel for testing and the actual flow will plop the CSV right in a database.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.