CSV READER - 'UTF-8' not supported.

I am having an issue with the CSV reader node.
I am trying to read a csv (cutsom url) with a CSV READER node and get te following error :
Execute failed: Content encoding ‘UTF-8’ not supported.
I am running KNIME 4.6.1.

I have no issues when i run this on KNIME 4.3.2.

i tried to update the knime.ini, and added “-Dfile.encoding=UTF-8”. without succes.

Have you tried explicitly setting encoding to UTF8 under the node configuration?


1 Like

Thanks for your quick reply.
Sorry i should have mentioned that. Yes i tried the encoding tab options, unfortunately no luck…

Hi @robbertth , if I remember correctly, I came across the same issue once. I just can’t remember how I dealt with it, since I tend to discard some ‘junk’ workflows in my local workspace from time to time. As a general rule of thumb, if I ever encountered issues with file reading, I always consider using the KNIME’s File Reader (Complex Format) to see if it solves an issue I encountered.

Have you tried using that? It might or might not help, but hopefully you’d give it a try. If you still face the same issue afterwards, you might have to upload the file so others can replicate the issue and propose a solution accordingly.

@robbertth could you provide us with a sample dataset (workflow) that would show the problem?

@badger101 - Thank you for your reply.
I have tried this without success.

Sure @mlauber71, find attached.
Thank you for checking, is just one NODE.

MP.knwf (5.3 KB)

@robbertth the Fixed Width File Reader – KNIME Hub is able to handle the connection. This seems to be no ‘normal’ CSV file but some response from a server…

1 Like

You are trying to read directly from an https server using a link. If you type in the link in your browser you will get to download the file behind the link. The actual file is different from the link.
You have two options here.

  • download the file and read it from your local disk
  • use http(s) conector in combination with the csv reader.

See the attached example.

MP_HTTP_READ.knwf (15.8 KB)


Thank you @temesgen-dadi.
I tried the https connector and that works fine, thank you.


1 Like

i can see that this works, but i think the solution with the http(s) connector is more elegant.

Thank you for your response though…

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.