CSV Writer cannot write file when running in batch mode

Running into an issue that the CSV writer do not complete (stay at “yellow”) when running under batch mode. Note that the file path is a Knime URL path using the format “knime://LOCAL/folder/file.csv”. The workflow runs with no problem when being executed under the Knime client non-batch mode. Also if the path is changed to a local file path (c:\folder\file.csv) then then the workflow is able to complete successfully under batch mode .

Any ideas?

In batch mode there are no mount points available hence you cannot use URLs that contain a mountpoint name. If you want to write files relative to your workflow, you can use a workflow relative URL, that should work.


Can one somehow fake a mountpoint or workspace in batch mode?
I would like to avoid copying gigabytes of inputs into each workflow of a set of workflows that before used the same workspace.
This would also be much better for sharing the workflows, because then I could share workflows and “workspace”=data separately.

I also would like to avoid adding “Edit variables” nodes in front of my dozens of inputs to make workflow variables viable.

Any help is appreciated.

@thor thanks for the quick reply.

Just to close the loop on this, I ended up using the path “knime://knime.workflow/…/{substitude_this_with_your_folder_name}”. This will reference the same location as LOCAL if your workflow is placed at the root directory of Knime.

Hey @kkam
Thanks a lot for posting your solution.
And I tried that as well, however it seems that when you use knwf files and pass them with -workflowFile
it unpacks them into an unknown temporary folder. Are you using knwfs or folders?
Actually, I could maybe try setting TMP to $(pwd). Let’s see.

So adding
-vmargs -Djava.io.tmpdir="$myworkspace" almost worked.
However, the batch executor adds an additional subfolder called BatchExecutorInputXYZ. I could change the relative path to knime.workflow/…/…/data but this is not very satisfactory because it is not easy to explain to other developers why this magic relative path needs to be used and it leads to unnecessary folder structures.

@jpfeuffer I am using the workflow in the folder format so I did not have the problem that you are experiencing. Sorry I can not help much but at least the solution is working. Like you said it would just need a bit of explanation.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.