csv writer giving me only one column in the output

Hey there!

So I am using the node CSV Writer to convert Excel tables to .csv and the output table is only written in one column, separated by commas.

I created this loop a couple months ago and it worked fine, but now it is showing this weird format. I was able to display it properly in Excel selecting all the data with the option “data to columns” and specifying the column break, but this is very annoying and used to be unnecessary.

Any idea what might have gone wrong?

Edit: what’s more concerning to me is that it is appending the data of the subsequent tables on the first file, and then producing as many copies of it as there are files. Here is my workflow so you can see what I’m working with. I understand this is an error in the loop but I cannot find it!

@rita_vp could you provide us with an example. Since CSV is -well- comma separated value it would seem the node does exactly what it is supposed to do. But you can always change the separator to a semicolon or something. If you say this worked before you might want to check for changing table structures or make sure they are the same every time.

If you want the data to be in Excel later question is why would you not export to Excel directly. You could just replace one tab or you could even insert data a a certain point with the new:

1 Like

I understand the .csv file is required to load the data onto another software or something like that, I am not sure because I am only preparing this for other people in my team.

Either way, I just updated my post because it is now seeming that it is only changing the file name of the tables but pasting in all of them the content of table 1.

When you open a csv file with excel it depends on excel’s default settings on what is interpreted as the separator meaning it your use the same separator when writing the file to csv as your local excel uses to interpret csv then you see individual columns in excel.
Eg. My local excel interprets “;” as separator so when I am writing a csv in KNIME with “,” als separator excel will show me everything in one cell and not in separate cells.

Hi @rita_vp , bottom line, what is the issue? :slight_smile:

Is it that (1) it’s writing all the data from different Excel files to the same csv file? And (2) multiple copies of the file is being created?

Can you share your workflow? If the files/data is confidential, you can give some dummy files, or worst case, just don’t include them.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.