Custom Profiles

As per the organization policy, we can run the apache only on HTTPS port and hence the administrator stopped serving the content on HTTP port. We have some workflows dependent on Python nodes and these nodes are not getting executed as it requires some extra packages which are installed in the conda environment. However, when we run this workflow, it always display a message saying the package is not found. After long checking, we realized that in knime.ini file in executor is pointing to but apache is not allowing this to happen. So we changed the URL to https://domain_name:8443/knime/rest/v4/profiles/contents and restarted both apache and executor. To our surprise, the executor is still trying to connect on HTTP URL only. Is there anything I am missing in this whole activity? Any help would be highly appreciated.

By the way, epf files are put in place and they are showing correctly. The environment is on RHEL.

If we hit the https url from our desktop, the file is getting downloaded properly and it is matching with what we are expecting. On the server when we curl the HTTPS URL, it is telling that it is trying to download However, when we do wget with the HTTPS url, it is still not working. Not sure if that is the default behavior.

Hi @kamtaot,
Is the executor running as a systemd service? In the service configuration, the profile URL might also be configured and supersedes the one in the ini. You can run sudo systemctl edit knime-executor to check.
Kind regards,

Hi @AlexanderFillbrunn, Thank you for your kind reply. I think we solved the problem. Couple of things that we did after which the custom profiles are getting loaded. Not sure which of the 2 or both were contributing to the issue.

  1. We changed the permissions to the client-profiles folder to 775.
  2. We changed the sequence of startup from Executor and then Apache to other way around.

Post which we could see that the profiles are getting loaded.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.