Dashboard Visualization Issue on KNIME: Configuration Help Needed

Hi Everyone :wave: :slightly_smiling_face:,

I’ve created a dashboard report and successfully run it on https://edu-hub.knime.com/. However, the visualization of the dashboard does not appear as it does in the 01.Data_Data_App workflow. Is there any additional configuration I need to do?


Hi @arief_rama,

I can confirm that the data app runs fine but doesn’t output a visualization. Unfortunately, I don’t have access to the workflow or I would take a closer look.

Best regards,
Stefan

1 Like

Hi @stelfrich

Thank you for addressing the technical challenge I’m facing :pray: :slightly_smiling_face:

You can review the uploaded workflow in detail by accessing this link.

Thanks for sharing the workflow, Arief!

I noticed two things immediately:

  • The workflow was uploaded in an executed state, at least to Community Hub: I am not 100% sure if this issue but it’s also not the best practice
  • You are using the Image Reader (Table) node: Replace it with the Read Images node, which will also allow you to get rid of most of the downstream nodes since the images are imported directly into a PNG column…

Best,
Stefan

2 Likes

Hi Stefan,

Thank you for the advice :pray::slightly_smiling_face:

I’ll address the technical issues tomorrow morning Jakarta time and update you with the results.

1 Like

Hi Stefan :wave: :slightly_smiling_face:

Today I have used the Data App Header and finally, the visualization dashboard is working :clap: :slightly_smiling_face:

However, I’mwondering why the KNIME logo is not appearing? :thinking: When I use the KNIME Analytics Platform for the visualization dashboard, the KNIME logo appears just fine.

KNIME Analytics Platform

KNIME Business Hub

This is due to a recent change around HTML sanitization in legacy nodes. The Image Output Widget (legacy) node is affected by the changes described in this section of the changelogs. You can give the Image View a try to get the same functionality.

Best regards,
Stefan

1 Like