Data Files not appearing in KNIME Explorer

Hey all,

Why can’t I see the data files associated with a workflow in the explorer as shown in this screen grab from a training video:


I only see the workflow file itself without associated data files:


Many thanks!

1 Like


Data files associated to each workflow is located in “TheData” folder under “Example Workflows” folder.


Hi Arming,

Thanks for your reply. But those data sets are only for the example workflows. Is it possible to see the data set associated with your own workflows in the explorer?

Thank you.

If your data files are in your workspace folder, they will be shown in KNIME Explorer. (If you’ve added a file while KNIME was running, you may have to refresh the KNIME Explorer to see the file)


1 Like

Hi Armin,

Thanks for your reply. However, I’m still not seeing the data after several restarts/refreshes:

  1. I created a sample project called ‘KNIME_project_test2’
  2. I added a spreadsheet with sales data to the workspace folder created for this project.
  3. I imported the data onto the canvas & refreshed.

As you can see in the second image, the explorer window still does not show the data file associated with this project, only the workflow file. Am I missing something?

Thank you.

You have put the file in project folder, you can move it to the root or create a new folder in your work space folder and put the project folder and the data file in it.

Hi @Haystack -

@armingrudd is correct here. Adding a reader node to the canvas will not cause the file you are reading to appear in the KNIME Explorer window; you will only see the file in the Explorer if the file is in that physical location on your file system. (Reader nodes can read files from anywhere that’s available on your system.)

Does that make sense?

1 Like

Hi @ScottF,

Thanks for your response. My issue is that I don’t see data files associated with any of my workflows in Explorer (whether or not I read the data).

In this example I created a new project called ‘KNIME_project_ABLE1.’ I added a file called ABLE1.csv to the workspace folder created for this project. As you can see from the image below, the file appears in the Navigator, but does not appear in Explorer.

I have seen examples in training videos (see graphic from original post) where the data associated with a workflow appears in Explorer, but I am not able to see my data. Also, I have kept all my default settings and use only the default workspace.

Sorry for the simple question, but it would be so convenient to interact with data sets in Explorer as I build my workflows. Thanks for your help!

Ah, OK. Thanks for clarifying.

In the KNIME Explorer window, you’re not going to be able to “drill down” into the workflow themselves - although, as you have seen, the workflows actually consists of a bunch of other files at the file system level. If you want to see data files via the KNIME Explorer window, they’ll need to be located somewhere other than inside a workflow directory.

The Navigator window DOES allow you to drill down, so I can see the source of confusion here. Maybe this is something we could consider tweaking the interface around, or at least documenting more clearly. I’ll bring it up internally - obviously we want to avoid causing confusion whenever possible!

Thanks for the clear and detailed input :slight_smile:

As I told you, the folder you are putting your data file in it is actually the project you have created. you have to put the data file in the work space and out of the project folder (If you wanna have the project and the data file in one folder, simply create a new folder in your work space and put the data file and the project folder in that folder)

One thing I should add is that using the knime:// protocol is helpful here. If I store files in a /data folder that is actually part of my workflow, I can reference those files using something like


whenever I need to interact with them in a node. This has the benefit of keeping my input files all in one place, and also as part of the workflow whenever I need to export and share with someone else. These files are hidden from the KNIME Explorer view, but still accessible.

@armingrudd @ScottF,

Thank you very much for your help!


Your suggestion helped. I created a new folder ‘ABLE Test’ in the workspace and copied the original project folder and separate data set into the folder. Now I see them both! However, strangely enough, the folder is missing in Navigator???

Thanks again for your help.

The Navigator doesn’t show the folders that you create manually. Instead it shows the workflow groups.
You can create a new workflow group and put your project and data files in it (instead of creating a new folder manually) or you can simply edit the folder name (right click on the folder and click rename) in KNIME Explorer and save it. Then it will appear in Navigator as well.

1 Like

Thanks, @armingrudd. The ‘rename’ trick helped show the folder in Navigator. Now, I can see all my files and folders in my workspace!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.