Date not recognized

KNIME does not recognize date value from a file, I have this excel file that contains data, one of the column contains date, but when I load it to KNIME, it does not recognized, I tried changing data type but no luck

Here’s my data sample.xlsx - Google Tabellen

sample.xlsx (10.2 KB)

Here’s what I’m getting

Hello @spyglass ,

there is something strange with your Excel file.
I tried to copy and paste your data on a new Excel file and everything was read as expected.

Another thing you could do is change the “posting date” column into the date format and then export the file as csv. Again, this is working on my KNIME.

Have a nice evening,
Raffaello Barri

Hi @spyglass and @lelloba , this issue rang bells, and whilst it might not be the same root cause, this looks remarkably similar to an issue that was raised here…


You have a strong memory @takbb :grinning:

Seems that resaving the file or saving it as csv should do the job.

Let us know @spyglass :slight_smile:



Saving as .csv fixed the problem, Thanks


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.