DB connector cannot run in batch mode

I want to schedule my workflow through batch mode and windows task scheduler.
But when I run the workflow in batch mode, it show errors.
The error message shows that the driver of DB connector cannot be found.
I try to assign specific preference file, but it didn’t work either.
I find that there is no driver information in my export preference file like “/instance/org.knime.database/drivers/”
So how can I solve this problem?

Bat file:

Blockquote
“C:\Users\cui.z.1\KNIME\knime.exe”^
-consoleLog -reset -nosave -nosplash ^
-application org.knime.product.KNIME_BATCH_APPLICATION
-preferences=“C:\Users\cui.z.1\KNIME\20220928.epf”^
-workflowDir=“C:\Users\cui.z.1\knime-workspace\Skin WF\0-Skin DataBase\16-D-1 InDex Report”

Error message.txt (5.8 KB)
preference file.txt (7.8 KB)

Uploading: knime preference-database driver.png…Uploading: knime preference-database driver.png…
Uploading: Error message.txt…Uploading: Error message.txt…