DB insert - Error


I am trying to insert data to SQL DB but I faced below error.

ERROR DB Insert 0:245 Execute failed: Error while adding rows #-1000 - #0, reason: Data truncation

I changed all varchar to longvarcart but still the same issue.

can someone help me to understand the issue and fix it.


Hi @Rawan,
what database system are you trying to insert data into?
Kind regards

I have the same issue with SQL server DB Writer. In old version it worked as I mapped input string to varchar(6000)

I am trying to connect to sql server.

did you use “DB insert” or legacy node.

In old version I used Database Writer. In new one DB Writer.

DB Writer it is fixed, I can only chose VARCHAR or LONGVARCHAR. and both didn’t work.

if you need to specify specific data types you need to use the DB Table Creator and the DB Insert node instead of the DB Writer node. The DB Table Creator node allows you to specify the type of each column to write whereas the DB Writer node uses a default mapping that can not be changed in the node for simplicity.


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.