DB Row Filter (labs) - cannot fetch values on Teradata connection

In the new DB nodes, as there is no option for Teradata, I configured the connection node to impersonate MS SQL Server. Everything works fine so far, except fetching possible field values in DB Row Filter - I get the Teradata syntax error 3706, complaining about the OFFSET clause.

The code which is sent to the database looks like this:

    (...) T 
    "last_lc_segment" OFFSET 0 ROWS

I guess Teradata doesn’t support OFFSET, but given that it is set to 0 - why is it needed at all?

Hello Dimitri,
we had to add the offset clause for MS SQL Server to allow the users to use the DB Sorter node since MS SQL supports ORDER BY statements in a sub-query only with the OFFSET statement. Do you experience problems with Teradata if you select the Default (e.g. SQL92 compliant) as database type? You can also tweak some of the generated statements via the Advanced tab of the DB Connector. If you still experience problems send us the problematic statements and we will see if we can add some more options to the Advanced tab that can help you.


I tried SQL92 first and had issues with Evaluate function - it uses LIMIT N instead of TOP N, Teradata needs TOP N.
I don’t think I can configure advanced options to exclude OFFSET clause, is it currently possible? Would be nice to have this hidden somewhere for those who needs it.

I see. Unfortunately you can not turn of the OFFSET clause for MS SQL since it is necessary. We will try to find a more general solution e.g. by providing a way to tweak the limit query via the advanced tab.