DB Table Creator creates table without data

Hi world,
I am trying to improve our Knime workflow by having data replace tables in our Snowflake tables. (In the future I will also want new data to be appended to other tables in Snowflake.).

However, right now I am stuck. I can successfully connect to Snowflake and create the table, but the data does not upload. I just get the table structure and column headers. Does anyone know why this is happening? I attach four screenshots, two from Knime, two from Snowflake.

How does the workflow look like?

Hi Daniel,
This is how it looks now. Please disregard the unconnected Node 261.

Ok so the Table creator gets a “filled” KNIME table as data input. Than it seems strange that it’s not working. I do not have snowflake myself. When I test with SQL Server it worked. Maybe someone else can help.

Hi @peterabraldes , I think that used like this the DB Table Creator only reads the table specification from the input data port if one has been configured, and from this it creates the (empty) table.

To write the data to the table, attach a DB Writer like this, and configure that with the require table name etc



Thank you @takbb ! This worked. This will save me a lot of time going foward!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.