DB Table Selector - Error Fetching Columns

I am having an issue with a workflow where the DB Table Selector will not read a certain table located within an oracle DB. There are other tables that work no problem all hooked up to the same Oracle Connector Node. When I go to “select a table” the error is 'Error Fetching Columns" and in the Console it shows error "ORA-00904: “Supervisor”: Invalid Identifier

This node has worked without issue for months, its not an issue with the table as I can access the data located in it through other software.

Any help would be great! Thank you

Do you use a special query with reference to certain columns or just a select *?

Could you give us some more context. Which versions of KNIME and DB nodes are you using. Are you able to access the table in question thru other means? Maybe DB SQL executor.

Have you tried using a fresh workflow with a new node?

Maybe someone from KNIME could read something if you provide a complete logfile.


1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.