DB Writer does not finish updating - MS SQL Server

DB writer does not finish executing. I am able to read from the db, but I cannot write. When I execute the Node 69 (yellow square) this does not execute.

Hi @yojed , i think you may need to give some further information as there could be a number of reasons.

From your description it sounds like there may be a lock on the table that you are writing to. If another process has it locked, sql sever would be waiting until the lock is released before it can write.

It may be something else entirely.

What is the message returned when you hover the mouse over the yellow exclamation mark on the DB Writer node?


Hi @takbb Brian, thank you for your response.

How can I figure if there is a lock? I am able able to get access to the database, which was my first major concern, not being able to write. However, I am using an user that has all access and most importantly, as you can see in my Node 60 and Node 59, I was able to access and read tables.

The DB Writer does not throw an error. It never stops executing, I apologize if the image was misleading as it shows with an ‘X’, but that came from me cancelling the execution.

I tried again in a new workflow and I get this error:
Please see image:

Message: Unhandled event loop exception

Exception Stack Trace:
java.lang.NullPointerException: Cannot invoke “com.knime.workbench.hubview.Browser.isBackEnabled()” because “this.m_browser” is null
at com.knime.workbench.hubview.HubView.finishLoading(HubView.java:488)
at com.knime.workbench.hubview.HubView.access$0(HubView.java:486)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:40)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:132)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4043)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3648)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$5.run(PartRenderingEngine.java:1155)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:338)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1046)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:155)
at org.eclipse.ui.internal.Workbench.lambda$3(Workbench.java:644)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:338)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:551)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:156)
at org.knime.product.rcp.KNIMEApplication.start(KNIMEApplication.java:191)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:203)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:136)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:402)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:255)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.base/java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:659)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:596)
at org.eclipse.equinox.launcher.Main.run(Main.java:1467)


java.vendor=Eclipse Adoptium
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Command-line arguments: -os win32 -ws win32 -arch x86_64

I checked in my console and I have these warmings. Please note that tried again and nwow my DB Writer does not stop executing again like before

The console said that the password is wrong and the database is not set… maybe the could the connection be closed in few seconds or disconnect because some setup at the node/database? the log make some appointments and your print others.

Tray make basic selection at the connection node to check it before go on.

Can you make a simple select table directly after the connection to test it too? Can you bring the print with mask fields but from the setup tabs?

If you can bring some values with it, your information or permitions are not allowed.

Try again please and give us some news…



This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.