DB writer problem

I have some problem using the DB writer node to append some rows to an existing table in a Microsoft Access DB.
My problem is that, when I run the writer node, it fails giving the following error message: Execute failed: UCAExc:::4.0.4 Could not find child entry in parent…
I know that the problem concerns a specific column but I have already verified that the format and the title are the same in the DB, so I don’t know what other checks to do.
Can you help me?

@rsemino I think we would nee more information in order to better understand the problem, like a logfile. If you could you might want to upload an example which demonstrates the error (without leaking secret informations of course).

One idea could be to first load the data into a temporary table and then insert it from within Access.

An example to play with:

1 Like

Hi @mlauber71, thanks for the reply.
Here’s the error message: “ERROR DB Insert 0:629:0:708 Execute failed: UCAExc:::4.0.4 Could not find child entry in parent; childEntry NodeEntry[rowId=6331:3,subPage=9412,bytes=(9) 7F 38 38 48 3E 48 3E 01 00]; parent NodeDataPage[6338] 0, 0, (9411)[entries=[NodeEntry[rowId=6330:3,subPage=9408,bytes=(9) 7F 38 36 48 36 48 36 01 00],NodeEntry[rowId=9821:2,subPage=43,bytes=(9) 7F 38 36 48 42 46 48 01 00],NodeEntry[rowId=327:3,subPage=9410,bytes=(9) 7F 38 38 48 38 44 36 01 00],NodeEntry[rowId=9526:6,subPage=9412,bytes=(9) 7F 38 38 48 42 40 40 01 00],NodeEntry[rowId=340:6,subPage=9608,bytes=(9) 7F 38 38 48 44 42 38 01 00]]] (Db=DB_Cert_Letture.accdb;Table=tbl_MAIN;Index=ID_Cong)”.

The DB writer node is correctly configured and trying to exclude the column I can run it without problems. The fact is that the column that is reported is of the same format as that of the DB Access and has nothing strange about it (it is a string of 6 alphanumeric characters).

I hope it is enough, alternatively I can try to load the node configuration screens.

Thanks a lot!

There are very few hints on the web about this error message. You could check several things:

  • are there any blanks or special characters in the column name (if so get rid of them)
  • does the target table have any auto-increments or keys
  • are there any other users using the MS access file at the same time
  • does the column have any special settings?
  • have you tried uploading the data into a special table and then doing the insert within MS access?

Here a combined index field with too long a name is mentioned:

You could then try and set up a small example on a fresh MS access do that would reproduce the error so we could investigate further.

1 Like

For me it sounds as conflict with index field. Does the problematic field is a part of any index?


Hi @rsemino , based on the message, it sounds more about a foreign key issue (parent - child).

I might be an issue with the fact that you are trying to insert the child records before the parent in this case.

If you have foreign key constraints in your tables, you need to first insert the parent records, and then the child records, that way the child is able to be linked to the parent.


I finally solved the problem, the problematic field was an index in the Access table so it was enough to change this option directly on the table.
Thansk everybody for the help!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.