Decimal point in KNIME

when I upload a csv file in KNIME after excecution table shows number only upto three decimal point and I need information of atleast upto 7-8 decimal points.

Sanp shot is attached

1 Like

Just change the cell renderer to full precision. (You can change globally in KNIME Preferences, or just locally by right-clicking on each column and selecting the renderer you prefer from the context menu.) The decimals are present in KNIME, just not visible by default.

2 Likes

Thanks. It worked.

I output data into an .xlsx worksheet and would like the data fixed on 1 decimal...somehow can't find the option under KNIME Preferences i.e. instead of 1,666666, I want 1.7

 

 

@ You can change globally in Knime Preferences

Where is the point in preferences, I searched for half an hour, but I probally overlooked it.
Can You tell me, where You found this.​

Greetings

Berthold

Hi Berhold,

I hope the following screenshot will help you find the setting (under File | Preferences):

Thank You very much aborg.

Threre it is.

For the sake of finding, I’d recommend leave those decimals on full precision, then round the result only where you need in a MATH node - round(x, y)

1 Like