Decision Tree Optimization Loop "reduced error pruning"

Hi everyone. Here’s a problem I’ve for quite a while and I can’t find the solution anywhere.

I’ve built a optimization loop for a decision tree learner and I can’t find a way to put “reduced error pruning” check box working in the loop. I’ve tried every different type of configurations on a table creator and table row to variable.

The error in the console is “Errors overwriting node settings with flow variables: Unable to parse “missing” (variable “reduced_error”) as boolean expression (settings parameter “enableReducedErrorPruning”)”

This are my configurations:



Can someone help me?

Hi there @robgomesp,

By the error message it is saying that flow variable “reduced_error” is missing. You sure variable with proper value is available in loop? If you can share example workflow with dummy data that would help in finding a solution :wink:


Thanks @ipazin,

where’s a workflow with my setup and the way I inject the variables in the loop.dummy data.knwf (33.4 KB)

That error only appears when i reset the workflow. But the results show this setting “reduced error pruning” don’t affect much the overall performance of the model. The first two best results are the same other parameters with reduced error pruning on and off.

Is this because the parameter don’t affect much the model, or because the parameter not entering correctly in the loop?

Once again, thanks.

Hi there,

tnx for example and btw nice workflow :wink:

I have checked it and your parameter enters correctly loop. You can check the value of parameter adding name next to the flow variable:


What you see in a console is not an error but a warning when Table Row To Variable Loop Start node is still not executed. Why it only shows for this one flow variable I’m not sure and will check.

Regarding reduced error pruning not affecting much the overall performance of the model - don’t think it has to. It should improve predictive accuracy by the reduction of overfitting. Check here:



Hi again!

Thanks a lot for the explanation and the quick response :smile:.
This was bugging me for years, and now I get it.

Once again, thank you.


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.