Decompose signal execution fails (invalid syntax (<string>, line 3))

Dear all,
I am trying to rebuild the steps for a time series analysis with a data set of monthly sales. After preparing the data and applying the Aggregation Granularity node, the table contains three columns, the aggregated time stamp in local date format and the sales numbers in integer format, and the granularity (string). It has 93 rows.

I have set up the Python preferences according to the manual here: KNIME Python Integration Guide

When I connect my data table to the Inspect Seasonality node or Decompose Signal node, the console shows the following error:
ERROR Python Script (1⇒1) (deprecated) 0:20:0:2 Execute failed: invalid syntax (, line 3)

I am not sure how to interpret the error and resolve the issue. Does line 3 refer to my own data table or the underlying Python code of the nodes?

I’m happy for any help or explanation!

Kind regards
Valerie

Dear Valerie,

Thanks for your question. I’d be glad to help. I don’t see anything wrong in the workflow. Would it be possible to share a screenshot of

  • the input table and

  • the configuration dialog

of one of the failing components?

Best,
Maarit

1 Like

Hello Maarit,
I have tried several options so far.
This is the .csv file
image
the Week_End column is already in the Excel date format, the Sales column is in Standard format.
I have converted the exact same file into .xlsx, however it did not work either. Skipping nodes like impute missing values or timestamp alignment (my set is complete anyways) didn’t help either.
Furthermore, I have done the entire data pre-processing from the file of origin of my small sample set in a workflow.

As this work flow has no error when used with the Energy usage file from the initial task set, the error is certainly somewhere on my side.

This is the configuration of the Decompose Signal node:
image

I have played around a bit with the lag parameter but without success.

I hope this helps to get a better understanding of the problem.

Greetings

Thank you for the additional details! I can’t find anything wrong in the input data or the configuration.

The problem might be in the Python integration. Can you execute the energy consumption workflow with the Inspect Seasonality/Decompose Signal components successfully in the same workspace?

If not, please follow this guide to setup the Python Integration and install the necessary packages for time series analysis in KNIME.

I hope this helps you!

1 Like