Greetings Knime Community.
I woulkd like to know if anyone is able to assist with the following case:
I need to install Tensorflow and Keras packages for Depp Learning affairs.
Initially I have installed the following extensions as per TSA algorithms demands:
- KNIME Python Integration
- KNIME Deep Learning - Keras Integration.
- KNIME Deep Learning - TensorFlow Integration.
Knime Analytics Platform Version: 4.6.4
Python version: 3.9.13
TensorFlow Package Version: 2.9.0
Keras Package Version: 2.9.0
Keras Version does not fit due to TensorFlow version package (2.9.1) which exceeds the one required for a proper functionality (Knime suggests versions from 1.0.0 until 2.0.0).
Based on the prior explanation I decided to downgrade Tensorflow package applying <pip upgrade tensorflow==2.0.0> however python didnt applied this action indicating impossibility to rewrite tensorlow, hence I had to uninstall Tensorflow; subsequently I reinstall Tensorflow again but this time using version 1.15.0 notwithstanding Anaconda Powershell shows and indicates impossibility to accomplish this action, please se the error below:
I am trying to install the sugggested tensorflow package version and so utilize keras, however KNIME Analytics Platform doesnt accept the latest tensorflow version and cant install an old tensorflow package version (from 1.0.0 until 2.0.0), so I am not really sure what exactly can I do.
Does anybody can provide technical criteria about how to solve this scenario?
Thanks in advance.