Difficulties making Google authentification and Gsheet reading/writing working

Hi all,

I am trying to read and write google sheets with a Knime AP workflow.

It basically consists in 3 nodes at the moment:

  • Google Authentification
  • Google Sheets Connection
  • Google Sheets Reader / Writer

At the moment, it does not work and I get the following problems, depending on how I set things up.

Case 1: company VPN turned on

  • I fail at authentication, with a “SocketTimeoutException” (I start authenticating, it opens up a page asking for authorizations, I do the approval and it then says “you may close this window”)
  • I cannot read nor write GSheets

Case 2: company VPN turned off

  • I manage to authenticate and I manage to read sheets on my personal drive
  • When I use the writer node, it stays at 99% and outputs a read timed out error, although it seems it manages to write the file anyway, despite the bug output

I am struggling understanding the issue and how to fix it, despite crawling the forum.
I would rather not have to turn off my company’s VPN and have bugs in my workflow, even though I may be able to write sheets that way.

Any ideas of how I could solve this issue? Potential leads I should look into?

Some details below:

  • Knime AP version is 4.5.3
  • Knime extensions, including Google extensions, are up to date in Knime AP
  • My company is working with Google stack, I use GSuite (GMail, GSheets…)


Hello @pimafr,

networking issues are always tricky to debug. However, as a starting point for further analysis you can check if the KNIME logs do contain additional information. You can access these logs in View → Open KNIME log. You can also change the log level of the logs to “DEBUG” in File → Preferences → KNIME. With that setting the logs will contain the most detailed information.

Best regards

1 Like

Hi @JoergWas ,

Thanks for allowing me to discover this new, valuable feature!
I will look into it.

@JoergWas so I looked into it.

Despite the timeout error, I do not have anything in the console and error logs, even with DEBUG set, aside from this img.

When I turn my VPN off, I actually can write data.
The reason I got the timeout was because it tried to write “too much” data on the google sheet at the same time.

Threads for other users related to timeout when writing (+ fix)

Threads for other users related to timeout when writing (+ fix)

In conclusion, I will not be able to debug this for now.
I believe the timeout parameter for Google products is in Knime’s dev team backlog. You may add a +1 to its value for me :smiley: , that feature could be helpful (but there must be many more helpful features in your backlog!)

Thanks for the feedback,

1 Like

Hello @pimafr,

thank you for researching the other links. I have added a +1 to the internal ticket.
Have you tried to use one of the solutions from the other topics? Especially the one with the Chunk Loop Start node (https://hub.knime.com/knime/extensions/org.knime.features.base/latest/org.knime.base.node.meta.looper.chunk.LoopStartChunkNodeFactory) looks very promising to me.

Best regards

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.