Disappearing rows

I've got an R Source (Table) node where I'm reading in a dataset from a csv and doing some basic preliminary cleaning. I'm using fread from the data.table package to read the 0.137gb file and it reports that there are 403739 rows and 49 columns.

The manipulation removes a row, so when I run nrow on what I assign to knime.out, I get the expected 403738. So far so good.

When I run the node, the output is 353758 rows and 49 columns! Where did the other rows go?!

I thought it might be something to do with rows entirely of missing values being automatically removed, so I tried creating a column in the dataset which would have a value (data$truth <- TRUE). It made no difference.

Any ideas?

Found something strange. The row count goes as follows:

...300018, 300019, 300020, 350001, 350002, 350003...

The final row number is 403738, which is what I'd expect if everything were working as it should.

Could you maybe attach a workflow where this happens? Then its easier to reproduce the problem.

Thank you,

Hi @Vexatious_Outlier!

Sorry about this, a race condition was causing a potential loss of a batch! This bug was fixed with KNIME AP 3.4.1.

Cheers, Jonathan.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.