dl4j 0.0 error per epoch

Hi all,
i have problem with dl4j.
No mater what i try error per epoch is 0.0 all the time not to mention prediction sucks after that :slight_smile: . Tryed all examples on server and its still the same.

Please help me, thank you.

Hi Josip,

Can you provide more details about the workflow you are running, what kind of data you use for training etc? Without this information it’s really hard to help you :slight_smile:



Hi Christian,
when i download examples from server, lets say knime://EXAMPLES/04_Analytics/14_Deep_Learning/01_DL4J/03_Network_Example_Of_A_Simple_MLP
network is not learning.
Also no mather what data i try or configuration i still get 0.0 error per epoch.
I dont have problem with weka or other DL just with DL4j.
The dl4j seems to use GPU and everything is ok but its always 0.0 per epoch.

Did you install the KNIME Image Processing - DeepLearning4J Extension from the “Community Contributions (Trusted)” update-site?

No, but after i did i still get 0.0 error per epoch. Currently i m installing all recommended extensions recommended by knime start screen. Will let you know what happened after update. Thank you

After installing all extensions error per epoch remain 0.0
Any further clues?

Can you provide the knime.log file? Maybe there is some valuable information in there.

knime.log (190.9 KB)
When i disable GPU usage for dl4j its working ok but it runs on CPU. When i switch back GPU it is still 0.0 error per epoch, so my guess it is problem with GPU, CUDA or something similar. Im using CUDA 7.5 validated.
Here is log file, thank you

Solved. Seems that CUDA drives was conflicting with regular GPU drives, so i installed drives from CUDA. Now its using GPU and error is normal again. Thank you for your time


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.