DL4J GPU setting Error messages with Windows 10 (64) G540m Knime3.5

Hi,

Is there anyone can point out what is missing?

I was able to use GPU setting to run most of examples in 04_Analysis/14_DeepLearning/01_DL4J (ex 03-10). The setting was Windows 10 64bit, Knime 3.5 (upgraded from3.4),cuda 8.0 and 9.1 (just installed). (java 8, update 161,both 32 and 64 bit installed)

When I was running the DL MNIST tutorial, my laptop had an unexpected shutdown. After reboot, when I start Knime, it complains it can only use cuda 7,5 and 8.0. with the following error messages:

ERROR RepositoryManager               MetaNode alexnet' from plugin 'org.knime.ext.dl4j.base' could not be created: org/deeplearning4j/nn/api/Model
ERROR RepositoryManager               MetaNode deepmlp' from plugin 'org.knime.ext.dl4j.base' could not be created: Could not initialize class org.knime.ext.dl4j.base.DLModelPortObject
ERROR RepositoryManager               MetaNode lenet' from plugin 'org.knime.ext.dl4j.base' could not be created: Could not initialize class org.knime.ext.dl4j.base.DLModelPortObject
ERROR RepositoryManager               MetaNode simplemlp' from plugin 'org.knime.ext.dl4j.base' could not be created: Could not initialize class org.knime.ext.dl4j.base.DLModelPortObject
ERROR RepositoryManager               MetaNode deepbelief' from plugin 'org.knime.ext.dl4j.base' could not be created: Could not initialize class org.knime.ext.dl4j.base.DLModelPortObject

So I uninstalled Cuda 9.1. when I restart Knime, if I didn't turn on the GPU selection DeepLearning 4J integration , (in preference/knime) there is no problem, if I check the GPU box, I got the above message again, and the "DeepLearning 4J integration" got another error message:

Unable to create the selected preference page.
An error occurred while automatically activating bundle org.knime.ext.dl4j.libs (486).

So far, I have tried the following:

1) reinstall all DL4J extensions;

2) reinstall Knime 3.5, and all DL4J extensions,

3) reinstall Cuda 8.0

I got the same results, if I use the previous  knime-workspace (with the GPU box checked), I got the same error messages and the "DeepLearning 4J integration" page can't be opened neither. If I start Knime with a new knime-workspace, it is ok but as soon as I turn on the  GPU selection, I got the same error messages and the "DeepLearning 4J integration" preference also busted.

Anyone has an idea what else I could try to bring my gpu back?

Thanks a lot!

Hi Toushi68,

sorry for your troubles. Could you maybe attach the knime.log file? Also, in Knime 3.5 there is a new option in the DL4J preference page to adjust the available off-heap memory limit DL4J is allowed to use. You could try to set that to the available memory of your GPU.

Cheers

David

 

Hi David,

 

Thank you for your reply. I have attached the log file. This is a "new" log file. I opened a new workspace, where I can open the DL4J preference page , select GPU option, increase the available off-heap memory limit to 4000, and checked the verbose option. After I restarted Knime, I got back the same error messages again.

Let me know if you need any other info.

Thanks

Toushi68

From this log file, it looks like java's issue?

Maybe it's from alexnet?

MetaNode alexnet' from plugin 'org.knime.ext.dl4j.base' could not be created: org/deeplearning4j/nn/api/Model

see this attached file

Hi Toushi68,

Thanks for the log file.

There seems to be a problem with your CUDA installation. The problem is caused by the following DL4J Exception:

"Caused by: org.nd4j.linalg.exception.ND4JIllegalStateException: CUDA backend requires compute capatibility of 3.0 and above to run."

The DL4J Integration will only run with CUDA 8.0 and a compatible GPU. What kind of GPU are you using? Maybe you could try to completely swipe CUDA from your computer and do a clean install of CUDA 8.0. Did you maybe change your hardware in between?

Cheers

David
 

Thank you David for pointing out the issue! It is a hardware problem.

Case closed.

Toushi68

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.