does weka 3.7 work?


Since 2.11 and into 3.0 the weka 3.7 nodes just dont work for weka predictor/classifier. Model is built fine, but that's a row error , even if the same data is used for prediction. Mining nodes work just fine and so do weka 3.6.

Windows or Linux does not matter. No one else facing this? 


I double checked using the last KNIME 3.0 version and I didn't encounter problems. There are a few known issues, e.g. with the settings in the Stacking-nodes, that are going to be fixed with 3.1 in December. However, most nodes should work fine.

Could you please give more information about the row error you encounter, or better, provide an example workflow where the problem occurs? That would be great. Thanks a lot!



Here's the workflow. If I just replace weka 3. 7 nodes with 3.6 or mining nodes like regression, there's no issue with prediction. It's been happening since 2.11. Even removing missing values or using same input table for prediction does not solve issues.

The weka predictor goes to 99% , takes it's sweet time and throws this error. Linu and Windows both have same issue. Another thread mentions it's a problem with columns having different types int vs double, but that's not the issue here

Error is

ERROR Weka Predictor (3.7) 2:39       Execute failed: Runtime class of object "10624.979762232117" (index 0) in row "Row3_Row3" is Number (double precision) and does not comply with its supposed superclass Number (integer)

I ran your node and inserted a missing value handler and then it worked. I also convertet the "time diff" column to integer since the values seem to justify that. MAybe it will work with the double also.

Another note: sometimes if you use the rename node to convert values eg from integer to double the result is not a 'real' double but some internal format. Some models do not like that.

It does seem to be a big regression of some sort. My 3.6 weka prediction nodes work just fine!. Looks like i may have to roll it back unless this is fixed. Something that works in an earlier version should keep working...

It's a solvable issue in this small wf, but for more complicated ones it takes too much time to debug ..

thanks for your inputs though.