Download of a workflow from the server fails

I am trying to download a fairly large workflow (~ 1 GB) from a server to my local workspace. What happens is that the download shows up in the progress window but then at some point just vanishes, and nothing is to be found in my local workspace.
In the KNIME log file I can see this (some parts replaced with XXX for privacy reasons):

2021-04-16 08:16:21,952 : DEBUG : Worker-16 :  : WorkflowDownload :  :  : Received server download stream for 'knime://XXX', storing it 'C:\Users\XXX\AppData\Local\Temp\1\KNIMEServerDownload3950588347098744640.tmp'
2021-04-16 08:19:14,907 : INFO  : Worker-16 :  : WorkflowDownload :  :  : Waiting for download to finish...(<XXX>)
2021-04-16 08:19:14,909 : ERROR : Worker-16 :  : WorkflowDownload :  :  : Unable to extract the download. error in opening zip file

So, apparently after the download the zip file can’t be extracted. If a watch the AppData\Temp\1 directory I can see that the tmp file is actually created but stays at a size of 0 Bytes(s) so nothing is being written to the file.
This only happens with one specific workflow, others can be downloaded just fine.

What’s going on here? How can I fix this?

Hi @mattflor ,

Thanks for reaching out. Can you help us try to narrow things down a bit by answering a few questions?

  1. Can you have one of your colleagues test and see if they get the same result?
  2. What version of KNIME Server and AP are you running?
  3. Does the workflow also have all of the data inside the workflow folder?
  4. Would it be possible to turn on debug logging for Knime AP, and try to reproduce the error again, and send us the log file?
  5. Have you tried the download while your computer was on a different network? Do you get the same results?
  6. Can you confirm that there is enough space on your computer in order to download the 1GB workflow?

Hopefully with the answers we can narrow this down and help you resolve this issue.