Duplicate column name "2" at positions 2 and 7

Hi. When I use scored, I have this error :
Duplicate column name "2" at positions 2 and 7.

what's it?


Obviously, you have two columns with the same name, "2", at the positions 2 and 7 ;o)

In KNIME the names of the columns must be unique!
You can use the Rename node in order to change the name of one of the two "2"' columns.

Does that help?

I better explain: I am using various types of datasets. Only with the last type datasets, I had this error.I not understand what is wrong. My columns have different names and this error shows up in only scored!

Ok, this seems to be a problem of different data types.
Please make sure that both columns you use for scoring are of the same type (look at the icon of the select box of the scorer). If they are of different types (e. g. Int and String), the Scorer tries to create the confusion matrix for each different cell with the string representation of the cells as the new column name. And "2"(string) would be different than 2 (int) but the names are equal. This probably leads to the exception.

Solution: ensure, that both columns you use in the scorer are of the same type. Use the String to Number or Number to String node.

Let me know if that solves the problem.

- Fabian

Unfortunately I can not to conduct the tests. I'm having the error "java heap space" when launching java snippet and scorer.is there a way to increase the size of the heap?

The -Xmx parameter defines the size of the heap space. You can either pass it on the command line or edit the knime.ini file in the installation directory.


Of course the value depends on your available memory ;o)

sorry if I disturb you again, but I am still inexperienced. I can not find the file you knime.ini me your word. You may explain more precisely how to modify the heap? : (

In the directory where you installed KNIME there must be a file called knime.ini (under linux it is .knime.ini).
Open the file, find the entry "-Xmx256m" and change it to "-Xmx1014m" for example.

If you use the developer version you have to edit the run configuration:
"Run -> "Open Run Dialog..." -> tab "Arguments" -> field VM arguments -> enter -Xmx1014M

Does that help?

By the way - you can also search our site: http://www.knime.org/search

or use the search box on the right.

There you can type in "heap" in order to find other explanations already given in this forum.

ok thanks! I don't find it because I use eclipse and then the file is eclipse.ini XD