Email Action when Worflow Fails

I was hoping someone could help me with this strange behavior. I have configured several workflows in my server so that I receive a notification when the flow fails. Here is an example of how I configured the scheduled execution:

The issue is that I started receiving a lot of emails, but the thing is that the email says that the flow executed successfully, although the subject of the email says that it was discarded because of inactivity. Is there way that I can make sure the flow will not be discarded due to “inactivity”? Is there a way I can avoid receiving email notifications if the issue is inactivity?

P.S.: The node that is running has a Python script that processes a lot of information; could it be that the flow spends a lot of time in the same node that it thinks it is inactive and ends the execution?

P.S.S: My Knime Analytics Platform is 4.1.0 and my server is 4.10.3

Hi Raul,

Could you please check on the knime-server.config of the KNIME Server how the following settings are set:

com.knime.server.job.max_execution_time=<duration with unit, e.g. 60m, 36h, or 2d> [RT]
Allows to set a maximum execution time for jobs. If a job is executing longer than this value it will be canceled and eventually discarded (see com.knime.server.job.discard_after_timeout option). The default is unlimited job execution time. Note that for this setting to work, com.knime.server.job.swap_check_interval needs to be set a value lower than com.knime.server.job.max_execution_time.

com.knime.server.job.discard_after_timeout=<true|false> [RT]
Specifies whether jobs that exceeded the maximum execution time should be canceled and discarded (true) or only canceled (false). May be used in conjunction with com.knime.server.job.max_execution_time option. The default (true) is to discard those jobs.

com.knime.server.job.max_lifetime=<duration with unit, e.g. 60m, 36h, or 2d> [RT]
Specifies the time of inactivity, before a job gets discarded (defaults to 7d), negative numbers disable forced auto-discard.


All these options are relevant how the KNIME Server handles automatically Jobs discarding.


Hi Raul,

it looks as if you got this mail because the job that ran on the 23. Nov. was discarded after a inactivity of 7 days (this is the default setting of com.knime.server.job.max_lifetime). This is not a failure, the job was executed successfully seven days before.

But you should only see these mails if the button “Notify if job is discarded due to inactivity” is activated. Maybe this option was activated on the schedule at the 23. November?