Embedding the WebDriver argument

Good morning.

@AnotherFraudUser, how are you? Please excuse me for bothering you once again. I cannot enter the WebDriver argument so that the process is not defined as a robot. For some reason, the process does not work.


image
image

1 Like

Hi @Nuke_Attokurov,

change the type from argument2 to argument.
Then it should work of the argument is supported by Firefox :slight_smile:

Yes, there is such an argument for Firefox. And it works. But for some reason it is not possible to pass the value.

Here’s the argument for Firefox:
ops.set_preference(“dom.webdriver.enabled”, False)


On this site, you can check whether the argument is valid. If the WebDriver is active, it will be green. If it doesn’t work, then it’s red:
https://intoli.com/blog/not-possible-to-block-chrome-headless/chrome-headless-test.html

image

It is not clear here, to be honest, how this argument is written. Or how it should be passed to the node configuration.

Hi @Nuke_Attokurov,

for set_preference of type boolean select preference type boolean.
Then first column is your dom.webdriver.enabled second part is false

So basically like the browser.tabs.remote example in your preferences :slight_smile:

But will check later if that option works for me :thinking:

*so your first line with dom.webdriver.enabled is correct.
It will execute the profile set preferences as intended :thinking:

1 Like

@Nuke_Attokurov so the problem is solved? :partying_face:

Oh yeah. Sorry there were too many tasks. I completely forgot to unsubscribe. Thank you so much.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.