Empty table customize

I am trying to put a filter on Payment received column ‘Y/N’ and I am extracting all the N’s in the excel.

If I apply column filter for ‘N’ it will create a empty table (that means i do not have any default) - when extracting this in excel I need the empty table to say “100%” compliance on the excel sheet

How to do this?

Hello @suseearun ,

You can use Empty Table Switch Node
Sends input data to first output if and only if it is not empty. If there are no rows in the input data the second output is activated (with the empty input table).


I need the extract to look like this (the above image). Though I use Empty table switch when i extract it all the columns are getting extracted.

@suseearun can you provide dummy data ??

Sales Rep.xlsx (9.8 KB)
If I filter all the ‘N’ from sales I will have empty data and when extracting I need the output to look like this

Hello @suseearun ,

If I understand your problem correctly , use above node like this

If after filtering you get a empty table, you can use any method to write a excel file as Nil (100% Complient) . Here I have used Add Empty rows.


You can use any other node after Empty Table Switch.


1 Like

Yes I have tried the above method. But the output looks like the below

but I want my output to looks like this


Could you help me with this please?

Hello @suseearun ,

Try this workflow.

QnA4.knwf (83.0 KB)


It Works. Still the column name ‘sales area’ is extracted in the excel.

There’s no way to remove it in KNIME?

Hi @suseearun,

Yes you can remove it.
When configuring the Excel Writer Node, just unclick on option Write Column Headers

This will Solve your issue.
Tell me If you need more help otherwise like and click on solution.


1 Like

I am extracting this excel along with 5 more excel in single excel writer. Hence if I choose this option, other sheets are also affected.

Any other way to do this?

You will have to use different excel writers for different situations.
I don’t know what exactly you want to do. So can you explain a little more. perhaps upload your workflow.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.