erlwood node not available in Repository Manager

HI, I have KNIME 3.5.1. I have installed Erlwood node and I used its, but from 2/3 weeks the node disappear from the repository. when I lunch a workflow with for example the 2d/3d scatterplot node I this message:

"2018-01-31 09:39:43,928 : ERROR : ModalContext : LoadWorkflowRunnable :  :  :     Status: Error: Node "2D/3D Scatterplot" not available from extension "Erlwood Knime Open Source Core" (provided by "Erlwood"; plugin "org.erlwood.knime.core" is not installed)"

If I try to install it the programs say that it is already installed.

I also see this messages in KNIME console:

"ERROR RepositoryManager               Node node.EvolutionaryAlgorithmNodeFactory' from plugin 'node' could not be created: Can't load factory class for node: node.EvolutionaryAlgorithmNodeFactory The corresponding plugin bundle could not be activated!
ERROR LoadWorkflowRunnable            Errors during load: Status: Error: repro5 beta 0 loaded with errors
ERROR LoadWorkflowRunnable              Status: Error: repro5 beta 0
ERROR LoadWorkflowRunnable                Status: Error: Node "2D/3D Scatterplot" not available from extension "Erlwood Knime Open Source Core" (provided by "Erlwood"; plugin "org.erlwood.knime.core" is not installed)"

I try to unistall and install erlwood node but nothing change.


some ideas to fix it?


Hi Baarzo,

So the "2D/3D Scatterplot" node did work on KNIME Analytics Platform 3.5.1 before and since 2-3 weeks it's not there anymore?

Did you install any additional extensions or updated KNIME AP since then?

And maybe could you please generate a log file by starting Analytics platform from the commandline with

knime.exe -consoleLog


Thank you!



yes the node stop to work after I had imported a workflow with some new nodes.


but know after another uninstallation of the node and another installation is back to work without any explanation....

Hi Baarzo,

Which nodes did you install before the earlwood nodes disappeared?



many nodes because was a big workflow but I can’t say which node was the real problem

I had installed Cresset node and nodepit. After this installation erlwood node expire again from repository.

I unistall and re-installed erlwood node bur nodes don’t appear again

if you uninstall cresset and nodepit, does Erlwood appear again?

I not try because I need to try the cresset node

I unistall NodePit and erlwood node doesn’t work yet

In case this helps. I imported a workflow using the pareto ranking onto a new computer. My Knime v3.5.1 detected that the node was missing and suggested I installed the “Erlwood Knime Open Source Core” extension. Turned out I had to install the “Erlwood Knime Open Source Cheminformatics” before that node worked for me.

after I had unistall cresset and unistall and installa again erlewood node the 2d/3d scatterplot is now avaiable

Hi All,

I’m having similar problems with trying to run a workflow that contains the Erlwood 2D/3D node. Getting exactly the same error message as above. I tried to uninstall and then reinstall the Erlwood extensions. I also tried to uninstall and the most recently installed extensions (which were the 3D-e-Chem KNIME nodes). Neither of these attempts worked. I’m running on KNIME AP version 3.5.3. Was a definitive cause and solution for the above issue identified? If so could you please share? Any help would be much appreciated
Thanks in advance,

it fill random sometimes, try unistall and reinstall the erlwood node later maybe work as happen at me one time

Many thanks for your suggestion Baarzo. I’ll try it again in a few days, but hopefully we can find a definitive solution to the problem.

We couldn’t reproduce the problem locally, We’ll further investigate. Can you provide your knime.log file?

now my erlwood node work, maybe @michazeidan

knime-server-logs (2).zip (2.6 MB)

Thanks for looking into this Christian. Please find attached log files.

Hi All,

we tried to install an uninstall the questionable extensions (Cresset, Erlwood, 3D-e-Chem, NodePit) in quite some different orders, but could not reproduce the issue yet, i’m afraid.

From @michazeidan’s logs it follows that a class org.erlwood.knime.nodes.graph.NGraphNodeFactory can not be found. I suspect that this gets somehow lost in the course of installing new software (even though that’s strange).

KNIME/Eclipse has a plugin installation history. It should be stored in a folder like
C:\Program Files\KNIME\p2\org.eclipse.equinox.p2.engine\profileRegistry\KNIMEProfile.profile\, where the C:\Program Files\KNIME\ part is the directory where you installed KNIME to. Could you zip that folder and attach it, please? With that, I could try and install the extensions in the same order you did and hopefully find some clues.

Best, Lukas

Hi Lukas,
Many thanks for looking into this and apologies for not responding sooner.

I’ve tried zipping the required file but it’s still too large at ~58MB…

Any suggestions?

try to upload on