Hi Marcel,

Thanks for the prompt reply. I did try to check the hosts file, but it wouldn’t allow me to open it:

What do you think I’m doing wrong?

I don’t know macOS too well, unfortunately, but this might be a permissions issue. Can you try to access the file via terminal, e.g., by using command cat /etc/hosts and - if this fails - do the same again as root user: sudo cat /etc/hosts and see if this works?

Some web search also suggests that unchecking the file’s “Locked” box under File > Get Info > General may help.

I fixed this by typing the following in Terminal: localhost broadcasthost

::1 localhost

Thank you, Marcel!

Now, I am having trouble locating R as described here (on another device):

. Here’s what I get when I type “r snippet”: .

Here’s what I see when I start R:

. So, it looks alright to me. And here’s what it looks like on Preferences > Knime > R-Scripting: .

I am new to Knime, as you can tell, so I do apologise for what must be very basic questions, but it’s quite frustrating when you get stuck. I appreciate you bearing with me as you provide assistance.

For KNIME and R you could refer to my article:

1 Like

Thank you for the link, @mlauber71. It did provide some guidance and I was finally able to install R Snippet via NodePit. However, it still won’t work and gives me the following message in the console: “WARN R Snippet 0:10 R Version 3.5.0 and Rserve <= 1.8-6 currently have issues preventing their full use in KNIME. A future release of R and/or Rserve may fix these issues.” And here’s what I get when I click on the node to configure:

. Can you please suggest something? I’ve almost despaired after three hours of trying to get around this. Thanks!

you have to install the latest version of RServe which is 1.8.6 - in order to do that you have to compile it. This should be described in the article. Also I would recommend installing the latest version of R (3.5.2). An on MacOS you also will need the Cairo package.

I’ve followed the instructions here and still got this error:

. Any idea what I may have done wrong?

you could try to add

, type = "source"

or you could try to install the package via Rstudio after you have installed the additional MacOS tools to compile packages.

Where exactly am I supposed to add it? By the way, I am running the latest versions of all the applications.

Will you please see the output to install.packages(‘Rserve’,“",type="source”) that I am getting: R Console.txt (16.6 KB) and maybe suggest something based on it.

I also tried to rerun the installation and got the same error messages, but the package was there in the ende (or it was still there). I have to investigate that. This error messages seems to be a new one:

library not found for -lssl

These are the two commands that I can think of to get the necessary libraries up and running. Unfortunately you will get some strange messages and I have no complete description how to succeed, just try several things until it sticks. We have seen some very strange things with R and KNIME unfortunately.


install.packages('~/Downloads/Rserve_1.8-6.tar', repos = NULL, type="source")

Also you should make sure the .tar file is complete, I have seen some strange things on Windows systems with packages that were just missing a few bytes.

Sorry for the troubles, I think we have a systematic problem.


OK I have one more piece of the puzzle and now it seems to work (again)

This instruction says for newer versions of MacOS you need an additional installation

sudo installer -pkg \ /Library/Developer/CommandLineTools/Packages/macOS_SDK_headers_for_macOS_10.14.pkg \ -target /

After I did this I was able to install RServe via the ‘regular’ command. As far as I understand the description this command makes certain paths/headers ‘known’ to the tools. Now I get a lot of warnings but in the end the compilation is done. I will have to investigate if it is feasible to provide a compiled version somewhere.

And also to bring all this together in a description …

I’m not sure what you meant by “make sure the .tar file is complete”, but I can report that after downloading the tar file, I just clicked on it, which resulting in a Rserve folder being downloaded:

I pasted what you suggested on Terminal and got the following:

Is this similar to what you got? That it says “invalid option” there makes me think something must have gone wrong.

I just did what I had been trying before and it didn’t seem to work for me, quite unfortunately. What exactly do you mean by the “regular” command? Do you run it on R or RStudio (if it makes any difference at all)?

unfortunately you will have to go thru all the installation steps and still will not have a guarantee that it will work.

I updated the article about KNIME and R with the last step. You may check if you have all the steps for MacOS mentioned there and see if you have the package like this:

Question is what version of MacOS do you have on your machine.


I am encountering this very same problem with Catalina, despite following the breadcrumbs on this and a couple of other KNIME/R/Rserve threads. For me, the bug seems to involve Clang. A screencap of the final error and the install log provided. Any insights appreciated.
Rserve_install_log.txt (18.4 KB)

1 Like

I think KNIME has a workaround (not yet published). Maybe @Mark_Ortmann can weight in on this. Or he might send the script mentioned in this thread to @longoka also.

I am sorry this is exactly how this feels. But I have not yet found a consistent way around it despite having written some sort of instruction:

1 Like

First install anaconda
this is link:
Second configure the ambinent according to what I wrote in the image.


just send you a PM containing the script we’re using to install RServe on MacOS >= Catalina.

Hope it works.

For everyone else. You’ll soonish find a description on how to install RServe etc. here (KNIME Integrations) including a link to the script.


Hi Mark,

could you share it with me as well.


I just want to give an update on my problem, for which I found a solution thanks to the efforts of @mlauber71 and @Mark_Ortmann. Thank you both.

I’m on MacOS Catalina, R3.6.3 and KNIME 4.1.2.

The compilation problem I was encountering installing Rserve 1.8.6 seems to have been related to trying this install from within RStudio. In the end, I needed to do everything from the command line using the steps:

  1. clarify openssl path: export LIBRARY_PATH=$LIBRARY_PATH:/usr/local/opt/openssl/lib/
  2. boot your specific R binary instance from the command line
  3. remove any earlier version of Rserve (e.g., 1.7-3.1): remove.packages(“Rserve”)
  4. clean install of Rserve 1.8.6: install.packages(“Rserve”,“”, type=“source”)

Clarifying the library path to openssl and performing all R operations from the command line is what facilitated the proper install of Rserve. Trying to do this from within RStudio was the issue (for me) that caused the clang and openssl compilation errors. R is now communicating with KNIME R snippet and view nodes, without error.

I hope this helps other Mac users who may be encountering the same problem.