ERROR Benchmark Nodes: fromIndex(1) > toIndex(0) when in component

Hi there,

I notices when enclosing the benchmark nodes, anyone btw, in a component, the following error is thrown when the option “Report node times” is activated.

ERROR Benchmark End (Memory Monitoring) 3:1334:0:1275 Execute failed: fromIndex(1) > toIndex(0)

Kind regards

1 Like

Thanks @mw - Will have a look and get back to you.

Could I check what version of KNIME you are using and OS? And do you have any other output in the console?

UPDATE: I have tracked down where this error is occuring - now I just need to figure out how to fix in KNIME 4.x without breaking it in KNIME 3.x versions - hopefully be able to roll out a fix in the next few days.



Was a little bit off the grid the past days. Deadly mens flue knocked me partially out. Glad to hear you managed to pin down the cause. Good luck fixing it. by the way, Knime 4.0.2 on OS X Mojave (not recent released Catalina).

Let me know when I shall try your fix on my machine.

Sorry for brnging this topic back from the dead, but the problem still persists in KNIME 4.4.2 (Windows 10 Vernalis version 1.30.3.v202112030505). Same error when used in a metanode. Basically “Report node times” setting is not usable inside nested views.

Hi @JFranek - sorry about this. It’s proving very difficult to track down (and impossible to replicate from our end at the moment still, although I know exactly which line in the code is throwing the error) - is there a workflow you can share with us which triggers the problem to help us try to figure it?



Sure, for example:

1 Like

@JFranek thank you! That’s really useful, and I can reproduce the problem.

We have test cases with components nested in metanodes, components nested in components, metanodes nested in components and metanodes nested in metanodes, which all work - but in all cases, those components or metanodes are within the loop body. What we don’t have is anything where the loop is itself within a metanode or component.

Now that I know where to start looking and have a test case to do it with, I will look into fixing this. In the meantime, the best I can offer is that you move the loop start/end outside any components or metanodes if possible.

Again, many thanks!


1 Like

A fix has just been released in v1.30.4 (available in nightly and stable builds 4.2, 4.3, 4.4 and 4.5)

Thanks for your patience with this - do let us know if you encounter any further problems.


1 Like

Unfortunately, I’ve updated Vernalis, but it still doesn’t work.
Tested with:
KNIME 4.4.2 - Vernalis 1.30.4.v202202030503
KNIME 4.5.1 - Vernalis 1.30.4.v202202030502

Hi @JFranek - very sorry - I have found the problem.

Somewhere on the way through transferring the fix from 4.2 → 4.3 → 4.4 → 4.5 → nightly, the fix for this bug fell out (the other fixes seem to have made it through OK, so not really sure what happened there). Unfortunately, but inevitably, the update to the test workflow also failed to propagate (I know what happened there - I forgot to do it :frowning: - sorry!) and so all looked OK with the builds.

I have set fresh builds going around 10 minutes ago. The fixed version should be available in around another 30 minutes from now (now = ~11.30am GMT) - it will still be 1.30.4, but the timestamp should update to something starting v20220304…

Again, my apologies, and thanks for pointing this out.


1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.