Error: Could not save workflow

Hi all,

I couldn’t find a post about it but I get this error message :

Could not save workflow: Writing of table to file at node Joiner 0:85:86 encountered error: IOException> The partition of the temp file “…” is too low on disc space. (84 mb available but at least 104857600MB required.) You can tweak the limit by changing “…” java property

I tried to increase the java heap space at knime.ini (it is xmx6g) but that didn’t seem to solve it.Does anyone know how to handle this error message?

Thanks in advance!

Hello @Francesca,

judging by error message you don’t have enough disk space. Can you check how much disk space is available? And how big is table in Joiner node?

Br,
Ivan

1 Like

Hi Ivan

I have 19 GB left from 118 GB in total on my laptop (did you mean this by disc space?)
The table in Joiner node has 438061 rows and 138 columns.

Hi @Francesca,

This error indicates that your temp directory is full, you can set the temp directory used by KNIME AP in the preferences:

best,
Gabriel

2 Likes

@Francesca you should check the settings in your joiner node. For me this sounds like you are creating a large amount of entries where eg. one column with few items is cross joined with another.

1 Like

Thanks
The only problem is that I still cant save the existing workflow as I have to restart Knime and my work gets lost…

Can you try resetting the workflow before saving it? That should greatly reduce the amount of data that needs to be saved.

best,
Gabriel

1 Like

Thanks Gabriel that worked!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.