Error in R nodes after upgrading R (version mismatch)

Hi,

I installed Interactive R extension and got the nodes working by installing rJava and adding R path to KNIME. This was on R 3.0.2. Then I upgraded R to 3.2.0, and installed rJava under the new environment.

Now when I try configuring R nodes, I get the error:

Error: R.DLL version does not match (DLL: 3,2,0, expecting: 3.0.2)

I have tried removing rJava from 3.0.2 depository, uninstalling R 3.0.2, re-installing R 3.2.0, etc. - nothing worked.

 

Can anyone help with this?

I can not help, but I am having a somewhat similar problem:  I finally put my R universe in order by specifying a common library, upgrading to R 3.2 and reinstalling all of my packagees but, of course, now KNIME throws me this error:

Error in .Internal(getOption(x)) :
  there is no .Internal function 'getOption'
Error in match.call(expand.dots = FALSE) :
  4 arguments passed to .Internal(match.call) which requires 3
Error in match.call(expand.dots = FALSE) :
  4 arguments passed to .Internal(match.call) which requires 3
Error in ls() : 3 arguments passed to .Internal(ls) which requires 2

If I switch back to R 3.1.2 everything works fine no matter which rJava library I point it to (i.e. R 3.1.2 rJava or R 3.2.0 rJava).  No clue what is going on.

So, I fixed my error by following these instructions:

https://groups.google.com/forum/#!msg/rapache/axLb5PsS9LY/7ZkP831LULkJ

I hope this helps someone else.

-Brian

Hi,

Did you manage to resolve this? I would like to have KNIME reference my installed version of R 3.2? Thanks.

Hi,

If you have this problem you can :

1 - install your own R

2 - rename all the R.dll in the native R knime directory by for example Rold.dll.

 

Best regards

Fabien

Hi,

Can I ask what was the source of the rJava and which directory where did you install it in? Thanks.

Hi,

the rJava Package is installed in both, it is from the beginning in the Knime R directory and I installed it in my own R library.

hi fabienc,

Do you mean it's installed automatically when I installed R or does it require a separte installation? Sorry if it's a basic question. So, if I re-install the latest version of R will rJava will come with it, and if not, where would I find it.to download? Thanks.

 

Hi,

On your new R install it manually.

Bes regards

Fabien

Ok, thanks. So, I just need to locate rJava on the CRAN site?

Yes exactly

Thanks for confirming fabienc.

I tried looking at some documentation for rJava and it appears that it was last updated in 2012 and may not work with versions of R that came out later.

I tried the steps suggested in this thread (renaming R.dll) but got the same error.

In my case, I have two versions of R installed, and I cannot install packages directly into R installation folder libary, so my packages are installed in [C:/Users/username/Documents/R/win-library/3.X] folder. R has no trobule using packages intalled there, but no matter what I tired, when I switch knime to R 3.2.0 I get the same R.dll error.

Hi,

I tired that and it didn't work, I got the same error.

I found two R.dll in KNIME extension folders, renamed them, and installed rJava in R 3.2.0 - no luck.

 

Reading the rJava documentation, it appears that it hasn't been updated from 2012, maybe it cannot work with R versions later than 3.0.2 ?