Error installing Vernalis extension

Hi. I’m trying to install the Vernalis extension on KNIME 4.1.1 but I get this error:
(Note: if it makes a difference, I have the KNIME Base Chemistry Types and nodes extension already installed). But here, it suggests I’m missing a knime streaming bundle?
Any help appreciated.

You need to install the streaming feature from the main KNIME update site. It is in the KNIME Labs extensions:

Hopefully that should then work OK.

Steve

1 Like

Hi. The KNIME Labs extensions category seems to be missing from the update site. Also, I tried to filter using “stream” and it returned nothing.

That’s strange - I just tried in KNIME 4.1 and I see it there. Might be worth clicking on the ‘Manage.,…’ button, selecting the 4.1 update site so that it is highlighted in blue as shown (not just that the checkbox is selected) and clicking on ‘Reload’ and trying again?

Steve

Hi. Good idea, but I tried and it still doesn’t show up.


Sorry - I’ve no idea what the problem there might be in that case. I’m going to tag @wiswedel and @thor in case they can see the problem. For reference, here is what I see:

Steve

Hi @dnaki,

if you go File --> Install KNIME Extensions what do you see?

Also you can try Drop&Drag functionality from KNIME Hub.

Br,
Ivan

1 Like

Hi @ipazin, Here’s what I see from File -> Install KNIME Extensions:
(Note: Thanks for the workaround. I’ll give it a try, though it would be nice to resolve why I don’t see Labs in the update site).
(Also please note that I am working with the latest KNIME version 4.1.1)

Hmmm… Drag and Drop from the hub also did not work…
image
image

Interesting.

It sometimes help to remove the update site URL and add it back again – it will then re-fetch the content (and I think do more than what “Reload” does). To be safe, maybe restart KNIME in between these steps.

Another idea: restart KNIME with “-clean” passed on commandline (or added to the knime.ini before “-vmargs”).

1 Like

Hi @wiswedel . I tried both suggestions as you described, but I still don’t see the Labs extension. Perhaps its time to reinstall? Can you confirm that others have installed 4.1.1 without this problem?
Thanks, Don.

Yeah, I think that’s best. I am running out of options.

We plan a bug fix release later today, so maybe you can wait until that is out.

Hi there @dnaki,

did re-install help?

Br,
Ivan

Hi. I just got around to reinstalling (this time KNIME 4.1.2) and was able to see the KNIME Labs update site, successfully install the streaming extension as well as the Vernalis extension. Thanks for the help!
-Don

2 Likes