The log says that the error is due to executor not being able to allocate memory. So either there is not enough memory allocated to the executor or the number that you allocate is larger than available on the system at that time.
The next debugging step either do what @quaeler suggested earlier or to set up a memory monitoring on the machine(s), where the server and the executor run. Then you can see the memory evolution at the moment of the crash.
See CPUUtilization high and jobs failed - AWS - knime server 4.9 for explanations on what is going on with the memory in your system.

