Error - JVM terminated - Knime Closed automatically

please look at error , this eror comesw and knime stop working and closed

while run multiple wkf

Hi @navinjadhav

please take the time and describe your problems when posting to the forum. without any description, we cannot help.

Where are you executing your workflows, which KNIME Server and AP versions are you using? Is this reproducible?

Thank you, Iris

I am using knime server small on AWS , Ubuntu… .knime 4.8.2.

when i run multiple workflow , i got this error and knime closed.

Are the workflows running on the server, are they running locally? Which AP Version are you using? How much resource does your system have?

Few of them are on server and few them on local…
i dont know what is mean by AP version and resource ??
it will be great if you can share how to check !!

MemTotal: 16424476 kB
MemFree: 3791148 kB
MemAvailable: 7576968 kB
Buffers: 208428 kB
Cached: 3807572 kB
SwapCached: 0 kB
Active: 9298484 kB
Inactive: 2936128 kB
Active(anon): 8219688 kB
Inactive(anon): 62308 kB
Active(file): 1078796 kB
Inactive(file): 2873820 kB
Unevictable: 112 kB
Mlocked: 112 kB
SwapTotal: 0 kB
SwapFree: 0 kB
Dirty: 1128 kB
Writeback: 0 kB
AnonPages: 8218788 kB
Mapped: 534312 kB
Shmem: 63388 kB
Slab: 268488 kB
SReclaimable: 167948 kB
SUnreclaim: 100540 kB
KernelStack: 12128 kB
PageTables: 50272 kB
NFS_Unstable: 0 kB
Bounce: 0 kB
WritebackTmp: 0 kB
CommitLimit: 8212236 kB
Committed_AS: 11686768 kB
VmallocTotal: 34359738367 kB
VmallocUsed: 0 kB
VmallocChunk: 0 kB
HardwareCorrupted: 0 kB
AnonHugePages: 0 kB
ShmemHugePages: 0 kB
ShmemPmdMapped: 0 kB
CmaTotal: 0 kB
CmaFree: 0 kB
HugePages_Total: 0
HugePages_Free: 0
HugePages_Rsvd: 0
HugePages_Surp: 0
Hugepagesize: 2048 kB
DirectMap4k: 186368 kB
DirectMap2M: 12396544 kB
DirectMap1G: 5242880 kB

free -m
total used free shared buff/cache available
Mem: 16039 8767 3140 96 4131 6847
Swap: 0 0 0
root@ip-172-31-26-36:~# ^C

Hi @navinjadhav,

The “AP version” means the “Analytics Platform version”, i.e. your local KNIME Analytics Platform. What version do you have installed on your machine?

Does the dump of the system correspond to the AWS instance or your local machine? Does your local Analytics Platform crash or the Server on AWS? From the screenshot it is hard to judge.


@lisovyi thanks for clarity…
I use AP 3.7… and server 4.8

I am not sure what exactly crashed !!

Hi @navinjadhav,

If the local Analytics Platform crashes, then the KNIME GUI on you screen most likely disappears or freezes and the error window appears on the screen of your machine. If something on the server crashes, then such error message would appear on the screen of the AWS machine and in your local KNIME GUI only the server would get disconnected. Which of the two is the situation that you observed?

Could you also elaborate on where did the memory configuration dump come from (local or AWS instance)?

Best regards,

i guess only knime client crash not server…

basically i have knime server on AWS - there were no UI for AWS instance - I got desktop UI for ubuntu. then i am able to run and see knime AP and web.

because i was not aware - how to open knime AP tool through CMD (WINSCP) or server
so installed desktop pckg to get UI on ubuntu machin. through which i open knime AP.

I guess memory config come from AWS instance , as nothing like local here.

everthing run on AWS instance

Thanks that adds clarity. But that in turn would mean that the ticket is wrongly tagged as KNIME Server. If AP crashes and the server runs, then it has nothing to do with the server and should be rather tagged with KNIME Analytics Platform.

There is still something in the situation that is not clear to me. Namely, do you run the KNIME AP client on your local computer or on the same AWS instance as the Server? Is it your local ubuntu machine? If so and the crash happened on the AP client side, then we would need the system configuration of your local computer not of the AWS instance.


OK… i need to write to AP i guess.

1)Do you run the KNIME AP client on your local computer or on the same AWS instance as the Server? - ans - on same AWS instance.

2)s it your local ubuntu machine? - i dont anything on my own laptop , everything run on AWS machine there is ubuntu installed , with knime server.

ok, that makes sense now.

Do both the AP client and the server run on the same AWS instance? If yes, how do you make sure that there are no resource clashes between the server and your AP client? If both of them claim a lot of RAM (more than half f the available memory) and you ran multiple workflows which require a lot of memory, then either of them or both could experience problems.

Is your problem reproducible? If yes, the first debugging step could be to monitor memory while you are running and see the memory status, when the crash occurs.

Additionally, you can have a look into solutions proposed in this SO discussion

1 Like

any permananent solution ?

Hi @navinjadhav,

it is hard to debug the situation remotely. Did you tryout the suggestions above?

Best regards,

1 Like

yes i tried it. and updated java

KNIME ships with its own java, so it will not be using the system java.

When you run KNIME, start it from its own terminal window (make sure that the terminal window has an infinite buffer so it does not start discarding old output in it.) After it crashes, copy the entire content in that terminal window into a text document and attach that text document to your next reply in this thread.


Please look into knime log.
we increased memory and cpu for aws instance this problem should not occur.

localhost.2019-09-24.log (647.0 KB)