Error Loading Workflow: 'other' has different root

I am trying to access a workflow from the Knime Hub and get the error ‘other’ has different root any ideas what is wrong? I can open from other computers and I have reloaded Knime on the affected PC but still get error.


I can’t even open an empty workflow, so it doesn’t seem related to any nodes that were used.

Hi @XiozTzu,

Does it still happen when you switch to a new workspace?

This only happens when I try to connect to a workspace in the Hub and connect to a Hub based workflow. Local workflows have no error and work as expected. Interestingly, I can upload a workflow from a local workspace and get no error, but get the error when I try to open a workflow from the Hub. The same workflow can be opened on other computers PC or Mac with no issue.

I only have the default local workspace on my machine. I do not have access to another hub to try downloading from. I will try uploading and using something from the public Hub.

Update: I tried to pull a workflow from my personal private workspace and get the same error.

Here is the log entry from Knime.log

2024-02-27 08:26:14,903 : ERROR : main : : OpenProject : : : Loading workflow… failed: ‘other’ has different root
java.lang.IllegalArgumentException: ‘other’ has different root

  • at java.base/sun.nio.fs.WindowsPath.relativize(Unknown Source)*
  • at java.base/sun.nio.fs.WindowsPath.relativize(Unknown Source)*
  • at org.knime.core.node.workflow.contextv2.AnalyticsPlatformExecutorInfoBuilderFactory$AnalyticsPlatformExecutorInfoBuilder.withMountpoint(*
  • at$4(*
  • at org.knime.core.node.workflow.contextv2.WorkflowContextV2$Builder.withAnalyticsPlatformExecutor(*
  • at*
  • at*
  • at*
  • at*
  • at$0(*
  • at$10(*
  • at org.eclipse.jface.operation.ModalContext$*

Yes, I understand. I meant if you change your local workspace to a new one (switch workspace in AP) and then try to open a workflow from Hub, do you have the same issue?

Ok, I made a new workspace in a temp folder and from there I could access a Hub workflow without error. Switching back to my default workspace makes the issue come back.

Hey, could it be that your default workspace is located under another drive letter than C:? This could explain the “different root”.

No, my Knime install is on C: and so is my default workspace.

C:\Knime\knime_5.2.1 (install location)

C:\Users\lastname\knime-workspace (workspace)

I do have my temp file set to D:\KnimeTemp

Did you create the new workspace, where it works, under D:?

I made the temp folder C:\Knime\Temp for workspace where it had the error, and it fixed the issue. So, I guess Knime developers should restrict temp folders to the same drive as workspace or fix the underlying issue. Or make a more informative error message.

I appreciate your help running this down!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Hi @XiozTzu,

we have released a fix as part of AP 5.2.2 (internal ticket NXT-2436).
Thanks for reporting the bug!