Error message No serialization library available for KNIME 4.5.1

Hi Team,
We upgraded our server to 4.14.1 and executor to 4.5.1.We are able to run workflows that don’t use any python script. However, when run the one that uses Python script, we got the error message below:
ERROR Python Script 4:1081:103: Execute failed: No serialization library available for id ‘org.knime.serialization.flatbuffers.column’. Available libraries:

As part of my troubleshooting, I did rerun the executor update script below , but I got the message ‘No Update Found’ in the screenshot attached

./update-executor.sh https://update.knime.com/analytics-platform/4.5

So now I’m running the command below under KNIME installation folder /var/knime to install the missing feature, but nothing is happening. Any help?

sudo ./knime -application org.eclipse.equinox.p2.director -r https://update.knime.com/analytics-platform/4.5 -i org.knime.serialization.flatbuffers.column

Hi team,
Any help here?

@pkamenga maybe take a look at these entries:

https://forum.knime.com/search?q=serialization.flatbuffers%20order:latest

1 Like

Hi @mlauber71,
I have followed some instructions in the link you provided by adding the line below to our server’s executor ‘.epf’ file, but getting the same error. here the screenshot of the epf file.

ERROR Python Source 0:885: Execute failed: No serialization library available for id ‘org.knime.serialization.flatbuffers.column’. Available libraries:

sorry here the line which was added tp the epf file

/instance/org.knime.python2/serializerId=org.knime.serialization.flatbuffers.column

@pkamenga you should maybe check if you use python 2 or 3. From my recollection there is no serialization for python 2.

1 Like

@mlauber71 ,
We use python3 as default Python. but we also have Python2

This looks like a problem with the KNIME installation to me. The serialization library mentioned in the error message is actually a fixed builtin part of the KNIME Python integration and should always be available. I would suggest to reinstall your KNIME executor. Perhaps reinstalling the KNIME Python integration also works, if you want to give this a try first.

1 Like

Hi Marcel,
I tried the installation of the missing extension by running the command below within the executor installation folder, but got the error message in the screenshot.

./knime -nosplash -consoleLog -application org.eclipse.equinox.p2.director -d pwd -i org.knime.features.core.columnar.feature.group

Hi @pkmenga,

Your executed command is missing the repository option where the extensions have to installed from.

Please use the following commands instead to uninstall all python features first:
./knime -nosplash -consoleLog -application org.eclipse.equinox.p2.director -u org.knime.features.python2.feature.group,org.knime.features.python3.scripting.feature.group,org.knime.knip.knimepython.feature.feature.group

And afterwards reinstall it again:
./knime -nosplash -consoleLog -application org.eclipse.equinox.p2.director -i org.knime.features.python2.feature.group,org.knime.features.python3.scripting.feature.group,org.knime.knip.knimepython.feature.feature.group -r https://update.knime.com/analytics-platform/4.5

Could you please try this and get back to me with the results?

Thanks,
Michael

1 Like

Hi @MichaelRespondek ,
Thank you for your willing to help. I did a fresh install of the executor and the serialization problem was solved. Now the only error message I’m getting is the message below. Do you have any idea?

ERROR Excel Writer 5:898: Execute failed: The directory ‘/…/data’ does not exist and must not be created due to user settings.

ERROR Excel Writer 5:900: Execute failed: The directory ‘/…/data’ does not exist and must not be created due to user settings.

ERROR Excel Writer 5:921: Execute failed: The directory ‘/…/data’ does not exist and must not be created due to user settings.

ERROR Excel Writer 5:990: Execute failed: The directory ‘/…/data’ does not exist and must not be created due to user settings

Paty

@MichealResondesk,
Here again the same error message
ERROR Excel Writer 12:900: Execute failed: The directory ‘/…/data’ does not exist and must not be created due to user settings.
ERROR Excel Writer 12:921: Execute failed: The directory ‘/…/data’ does not exist and must not be created due to user settings

Hi Paty,

Thanks for your quick reply, good to hear, that the origin issue was solved by a re-installation of the Executor.

I assume that you configured the “Write to” Option to “Relative to” “Current workflow data area” and haven’t activated the “Create missing folders” option.

This should fix your issue.

Best,
Michael

1 Like

Hi @Micheal,
Thank you for responding. I tried to the change the excel writer config as per your instruction and got the same error message. I want also to precise that this happens since we upgraded to the server 4.14.1 and executor 4.5.1

@pkamenga from the screenshot your setting of the path is inconsistent. You can either have relative to current workflow or KNIME URL but not both at the same time.

And in you choose current workflow data area you can not use relative path to go further up to get to a folder at the same level as the workflow. Not 100% sure if this is intentional.

https://docs.knime.com/latest/analytics_platform_file_handling_guide/index.html#introduction

2 Likes

Hi @mlauber71,
Thank you for responding and willing to help. I have tried the config as per the screenshot below and got the error message below

Excel Writer 0:900 - ERROR: Execute failed: Server returned HTTP response code: 400 for URL: https://urbknime2.admin.uillinois.edu:8443/knime/rest/v4/repository/Paty-Troubleshouting-upgrade/PROCUREMENT_1.03/PROCUREMENT_BUYER_RPTS_PK/assigned_buyer.xlsx:data

Hi @mlauber71,
This is an update that my issue was fixed after I have applied the configuration below on the Excel Writer node. Thank you for willing to assist.

2 Likes

Sorry image was not clear.

2 Likes

Thanks for providing the working setup. You could achieve the same by configuring these settings:
Write to: Relative to Current workflow data area
File: Buyer_Inbox_1.xlsx
And the activated Write options X Create missing folders If exists: x overwrite
I mention it just to make it easier to configure the next Excel Writer nodes on different workflows.

Best,
Michael

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.