Error message: path doesn't exist, while using "SharePoint Online Connector"

In node SharePoint Online Connector:

When I configure “Sharepoint site” by inputting “Web URL”, it always gives below message:
Execute failed: The provided path does not exist, or does not represent a site

Sharepoint link is actually from Microsoft Teams-Files-copy link. Tried below methods but most are failed:

  1. Remove “.f.” characters from sharepoint link, failed;
  2. Remove “%20” from “Shared%20Documents”, failed;

Is there a way to let the node know sharepoint link?

Root cause identified with an explanation I need stop inputting URL with first part, ended at site name. Then it works well.

Still no sense on work directory.

Hi @skozer,

I am glad that you figured it out on your own. So by default the root working directory is represented by a “\” sign. However to get to the specific folder you can always navigate to it using “Browse” button.

Just a tip, incase you are unsure where files and folders are located, you can always use a “List Files/Folders” node. Remember to enable the File port connection on the input and select the options in configuration window as in the attachment below:

BR,
Ali

1 Like