Error (no connection data found) upon PC Restart when using Web Interaction nodes

Hello!

I am new to the Web Interaction (Labs) extension and facing an issue getting started with accessing a web page.

The simple workflow (attached) consists only of a Web Interaction Start and a Navigator node. Upon initial build and even after restarting KNIME, this workflow executes successfully.

However, after restarting my computer and attempting to execute the workflow again, I receive the following error in the Navigator node:

Execute failed: No connection data found. Re-execute the upstream node to refresh the connection.

KNIME Version: 5.25

Troubleshooting Steps thus far:

  • Directed the Web Interaction Start node via filepath to my chrome.exe file
  • Re-executing after receiving the error message (as instructed by the message)
  • Changing the URL to which the Navigator is navigating (including using a full URL)
  • Deleting all nodes and rebuilding the workflow (works temporarily before the error persists after another PC restart).
  • Copying community-built workflows from the KNIME Hub and testing (the attached .knwf actually originated as one of these copies. Interestingly, the full workflow executed successfully after a PC restart, but when I deleted the other nodes and retried with only the Web Interaction Start and Navigator nodes, I began to face the same error).

There must be something simple I am overlooking. Thank you for your help!

Web Interaction Test.knwf (77.9 KB)

1 Like

Hello @rks879,

Welcome to the Community!

Thanks for providing a sample workflow, I downloaded it and followed your steps to reproduce the bug you are encountering.

Steps:

  1. Run the workflow (the 2 nodes)
  2. After they both execute, save the workflow
  3. Restart the computer

After doing the 3 steps above, I was able to reproduce the bug you mention running into. I was able to get it running once by resetting the nodes and closing KAP, but I have tried this method again and it seems to be stuck at the error message you mention.

I will be creating a ticket for this as you found a bug that is reproducible on my end also.

Once I get the ticket up I will respond and attach it in this thread.

Hope this helps,
TL

2 Likes

Hello @rks879,

I have created a ticket detailing the bug: AP-22701

As for a quick workaround, I was able to get it running by doing a simple:
Ctrl-X → Ctrl-V (or Command-X → Command-V if you are on mac)

TL

1 Like

Hey @rks879,
did you try reset the Web Interaction Starter Node as well and not only the Navigator? The starter opens up the browser to be used and after a restart of your PC, you’d need to start it again.

Best,
Alex

3 Likes

@Alex_JW,

Here is my documentation for the issue after restarting:
screen

I have also attached it to the ticket for documentation

TL