error on get request node

hi, I´m trying to use a very simple get api (Brazilian postal codes), with following simple workflow:

Even when try static api, always get the error " ? " at get request node . Ive use this api several times, on other places and works very well. Clues?

Hi @SilasCoelho , I don’t think we can really tell you much from just looking at a picture of some nodes other than that “there is probably something wrong” :wink:

Have you told it to “Fail” on errors in the Error Handling tab of GET Request?

That way, instead of this:

You might get this:
image

It won’t necessarily explain why it failed, but at least you can see it failed!

Other than that, I think you’re likely going to have to share some config or info on the data you pass, and better still, if it’s a public api, and no sensitive data, upload a demo workflow., as there could be any number of reasons for the failure, from a simple typo or missing parameter, or that you need a session key/token to access the api.

3 Likes

Hi @takbb , sorry, I should add info before hands. Anyway, When I use the Get Request node, with the api adresss ( https://cep.awesomeapi.com.br/json/05424020), also give me an error ( Execute failed: java.lang.IllegalArgumentException: Illegal character in scheme name at index 0: https://cep.awesomeapi.com.br/json/05424020)

It is a public , no any key, api. Works pretty well on browser, straight from the http line

1 Like

I tried your address
https://cep.awesomeapi.com.br/json/05424020
and it works fine with the get request for me (KNIME 5.2)
Have you tried other api calls to check that it is not some issue with your KNIME installation?
br

1 Like

@Daniel_Weikert , let me check the instalation, tks for now :wink:

1 Like

Hi @SilasCoelho

I can replicate the error.

I think you most likely have a space at the beginning of the URL

instead of

3 Likes

Hi @takbb, it is correct, that was the mistake. Working just fine now. Txs a lot!

3 Likes

Hi @SilasCoelho , glad to hear it’s working.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.