Error R Snippet

Hey everyone!

First time on the forum and new to Knime so apologies if this is in the wrong place or if I haven’t provided enough information.
I’m using a workflow that connects to R via Rserve. Whenever I try and run the node that is connected to R, I’m getting the following error in my console:

0:1440:0:2045 Execute failed: Exception occured during R initialization.

I’ve uninstalled and reinstalled most recent versions of R, Rtools, Rserve, I’ve checked my Preferences within Knime, checked the environment variables on my PC, checked the PATH in my R environment - and have restarted Knime several times but am still getting the same error.

I’m not sure what else to try so any help or suggestions are appreciated!
Best wishes,

Did you follow these instructions?



Hi Mark - I hadn’t seen this documentation so thank you for forwarding it! What fixed it was installing an older version of Rtools and then manually creating the path in my environmental variables - but wouldn’t have thought of doing this if it wasn’t for the link. Thank you for your help :slight_smile:

Cheers, Kate


Hey @kiegallagher,

I agree it’s somewhat hard to find all our documentation.

I’m happy to hear that you were able to find a solution that works, though the documentation did not fully cover your problem. May I ask what R version you’re running and which versions of Rtools did not work + which did?


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.