Error reading multiple excel files in a loop - "Not valid OOXML File"

I am trying to read multiple excel files (all .xlsx) in a loop, but I keep getting this error:

Execute failed: No valid entries or contents found, this is not a valid OOXML (Office Open XML) file

Any ideas on how I can fix this?


Getting this error now:

Execute failed: org.apache.poi.openxml4j.exceptions.NotOfficeXmlFileException: No valid entries or contents found, this is not a valid OOXML (Office Open XML) file

1 Like

These are the steps I see:

  • make sure it is actually a valid Excel File
  • use the new Excel Reader (not the deprecated one) and see if that makes any difference
  • restart KNIME once with the “-clean” setting

You could provide us wth a sample of one file that would not load to reproduce the error; if it does not contain any sensitive informations.


Hi @vivianmpoon,

it really sounds like you’re trying to read an invalid file. Which software was used to create the file? As @mlauber71 already pointed out, it would be helpful if you could share a sample of your data.




Unfortunately I am not able to share the data as it has sensitive information.

  • I have checked that the files are indeed a valid Excel file
  • I tried using the new version of the excel reader but it didn’t work, which was why I tried to use the deprecated one
  • I tried restarting Knime with the -clean setting as well and it did not work.

Not sure what the issue is because I used the exact same files from the prior month and it worked before (no changes were made to those files). The only thing that has changed is that I added a new file to the folder, so I tried to remove the new file to see if that was what’s causing the issue, but the error still persists

Hi @vivianmpoon

are you able to create a new file with dummy data that fails for you? So that I can take a look and investigate the issue.



Most likely it still is a problem with the Excel File. Another thing you might try is use R packages like openxlsx or readxl to import the Excel File and see if this succeeds. This could give you further information about the nature of the problem.

And as @SimonS said: an example reproducing the error might go a long way in solving this.

Funny thing…as I was trying to recreate the error, I saved the files in another folder and it worked! I guess there was something about that particular folder the files were originally in…


Perhaps some access restrictions?

However, glad to hear it’s working now :slight_smile:

In theory it could be that your hard drive or ssd is compromised. You might want to check them and see if you have a working backup and file versioning.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.