Error Redfield BERT Installation in Mac M1

Hi

An error occurred while installing the items

session context was:(profile=KNIMEProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=[R]se.redfield.bert.channel.bin.macosx.x86_64 1.0.3.202402210241 → [R]se.redfield.bert.channel.bin.macosx.x86_64 1.0.3.202405240152, action=org.knime.product.p2.actions.ShellExec).

ShellExec command exited non-zero exit value:

Not sure why this is failing during Installation of Redfield BERT Nodes.

Worth to check it out.

Regards,

AG

Hi @VAGR_ISK,

could you please share the two log files described in the following troubleshoot section? KNIME Python Integration Guide

Thanks
Steffen

I have the same problem with KNIME 5.2 on Windows.
create_env.err (928 Bytes)
create_env.out (16.8 KB)

@VAGR_ISK you can try and use the Intel version on the M1 - with that I had less problems with extension installations. Or it is specific to python extensions …

Thanks @tohshima for the details.

That is an issue which surfaced with the new build of the Redfield BERT extension, which happened on 24th May. We are unsure why the build of that extension is now failing and are investigating.

Best regards
Steffen

EDIT: Tagging the maintainer @Redfield

Hi @VAGR_ISK

Thanks for using Redfield BERT Nodes :grinning:

I am unable to reproduce the same error on macOS M1. I installed the extension without any issues in KNIME 5.2.3 (Apple silicon). If you are not using KNIME (Apple silicon), could you please try it?

Please let us know if you are still facing any issues.

1 Like

Hi all,

I think we identified the issue and I pushed a fix and made a new build. As @abderrahimala wrote, it should be working now again and you should be able to install the extension.

Please tell me whether that worked.
Steffen

PS: technical details. A new build of the BERT extension used a more recent version of setuptools. That version had the method convert_path removed. That removal resulted in the end in the error message you have in your create_env.err.

4 Likes

Ok @steffen_KNIME thanks. The installation did work. :star_struck:

AG

1 Like