Error running Workflow as bat

I have a workflow that Reads data from a DB2 table and then Writes to a Teradata table. If I run the workflow from Knime it runs, but when I run it as a bat file I get this error below. The bat does not exit and also I am not able to do a Select on the Teradata table, it seems to be hung up.

This is my bat file:
START “” “C:\Program Files\KNIME\knime.exe” -nosave -nosplash -consoleLog -reset -application org.knime.product.KNIME_BATCH_APPLICATION -workflowDir="G:\PRODNET\Reporting and Administration\Reporting_Library\Workflows\Knime\Test5431

Below is the error:
2019-05-28.15:32:18.684 TERAJDBC4 ERROR [main] TeraDriver/ The com.ncr.teradata.TeraDriver class name is deprecated. Please use the com.teradata.jdbc.TeraDriver class name instead.
INFO main BatchExecutor ===== Executing workflow G:\PRODNET\Reporting and Administration\Reporting_Library\Workflows\Knime\Test5431 =====
SLF4J: Failed to load class “org.slf4j.impl.StaticLoggerBinder”.
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See for further details.
ERROR pool-1-thread-1 Shell Failed to locate the winutils binary in the hadoop binary path Could not locate executable null\bin\winutils.exe in the Hadoop binaries.
at org.apache.hadoop.util.Shell.getQualifiedBinPath(
at org.apache.hadoop.util.Shell.getWinUtilsPath(
at org.apache.hadoop.util.Shell.(
at org.apache.hadoop.util.StringUtils.(
at com.pervasive.datarush.hadoop.shims.HDFSShimImpl$
at com.pervasive.datarush.hadoop.shims.HDFSShimImpl$
at java.util.concurrent.ThreadPoolExecutor.runWorker(
at java.util.concurrent.ThreadPoolExecutor$
Error enabling datarush update site: null
Error while adding dataflow workbench listener: Workbench has not been created yet.

Presumably when you run KNIME on the desktop, you have set the preferences to tell it where to find the Hadoop binaries; make sure you include a pointer to the preferences when running on command line -

so my workflow doesn’t use Hadoop, but it does give the error. Can you clarify what the Hadoop binaries would be and how you would use the -preferences in the bat

Hmm - it’s inexplicable, then (to me) how you have a stack trace complaining that the execution ran into problems trying to locate the Hadoop binaries. If you go to your Preferences and you type Hadoop into the search field, does anything show up? Anything in the Teradata specific preferences seem related?

To cite the preferences in the bat invocation, the easiest way would be to export them via File → Export Preferences… and then specify the fullpath to that exported file.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.