Error when attempting to config Excel Reader Node: failed to apply settings: java.lang.NoSuchMethodError: 'void'

Hi Community!

I am on 5.2, windows 11.

I am seeing this error (failed to apply settings: java.lang.NoSuchMethodError: ‘void’) when I try to browse for a file in the excel reader node - NOT when executing. It does not even allow me to attempt to execute because it will not allow me to specify which file to read.

Coworkers are not having this issue - they are on the same knime version and OS.

Thank you so much for any and all advice!

Hi @balest01,

and welcome to the Knime community. Can you post a screenshot or a test workflow please?


I do have the same error. All excel files that I add to my computer present the same error

Hi @balest01 and @yzanferrari,

that sounds like a dependency version unfortunately wasn’t configured correctly in the last update you installed. You’ll need to update the feature “KNIME File Handling Core” to version 5.2.1.v202403051007, which contains the missing method ExcelMultiTableReadConfig.setCheckSavedTableSpec(boolean).

  1. Go to “Menu” → “Install extensions”
  2. Uncheck the box “Group items by category”
  3. Find the feature “KNIME File Handling Core” (there’s a search bar above the list)
  4. Make sure that the version is (at least) 5.2.1.v202403051007 and install the feature

I hope this works for both of you, and sorry on behalf of the Dev team for the inconvenience!

Edit: You can even uninstall the “KNIME File Handling Core” feature again right afterwards to avoid warnings in future updates, the underlying code will stay updated. Features are only groupings of plugins, which contain the implementing code.


Thanks @leo_woerteler! On my case it did solve.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.