Error while adding Column Expressions Node in version 4.7

Hi everyone! I’m trying to add the column expressions node to my Knime version 4.7. I read some of the posts in the community, and I already reinstalled the program and verified it’s not about my internet restrictions, etc. I’m trying to install the node by dragging it from this page Column Expressions – KNIME Community Hub

don’t know if there’s a different way to install it.

This is the error:
image

This is are my preferences:
image

Really appreciate your help.

Best regards,
Pol.

Hi @03751395 and welcome to the KNIME community forum,

I think you have disabled/removed the KNIME Community Hub mountpoint.
Would you check preferences > KNIME Explorer and make sure that KNIME Community Hub is there and enabled?

1 Like

Hi,

First of all, thank you for your reply, you were fast!!!

It wasn’t enabled, now it is but still dosen’t work…

Can you see “My-KNIME-Hub” in your KNIME Explorer? (The top left panel in KNIME workbench)

Yes, and when I double click to connect it show me the following error:

It seems your AP cannot access https://api.hub.knime.com/knime/rest

Are you using an authenticated proxy?

2 Likes

I think so, I switch my company’s wifi to another one and allowed me to log in with my user, but 1 minute after it automatically disconnected… Also my computer is from the company, but I have other teammates that are also using Knime and they where allowed to add the Column Expressions Node.

Have you set up an authenticated proxy in KNIME AP?
You can check this by going to preferences > General > Network Connections. See if the “Active Provider” is set “Manual” and an authenticated proxy is set for HTTP/HTTPS.

1 Like

I didn’t set up anything.

That’s what i see when i select the manual option:

So, you have not set a proxy in AP.

Would you try to access the URL in a browser on your machine?

https://api.hub.knime.com/knime/rest

Also, if possible, please check your firewall settings and make sure it is not blocked there.

This is what I see, don’t understand at all what are you looking for, sorry for my ignorance…

No problem. It means you can access the URL in the browser.
Did you check your firewall settings?

Yes, dind’t see anything

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.