Error while installing Extensions for SCHRODINGER

I am very new to the KNIME environment and apologise in advance if I am not doing something correctly. I m trying to prepare a KNIME analytics platform for myself that include the ligand preparation workflow from SCHRODINGER.

I drag and drop the node into my platform, then it asks to install the Pharmacelera extension but during the installation I receive an error. In the log file (if I am checking the correct log file?) it says that SCHRODINGER is not set properly. I don’t know how to set it properly?
One thing I have tried is through the KNIME setting and added the Schrodinger directory to my path, the error still exists.

Hello @tahami - Welcome to the KNIME Forum!

Can you let us know what version of KNIME you are using? Also, can you try installing the extension again to make sure that error wasn’t from a different event? When you hit ‘next’ on the install dialog, you should get more information.

I’m thinking the SCHRODINGER error happened when you first opened KNIME. These two extensions aren’t dependent on each other so it shouldn’t block Pharmacelera.

Thank you,

1 Like

Hi, I have tried it many times. It doesn’t give me more information by clicking on the Next bottom.

Maestro version 13.8.135, MMshare Version 6.4.135, Release 2023-4, Platform Darwin-x86_64

KNIME 5.2.0

using the “Setup Diagnosis” node, it says that KNIME extension is not compatible with my mmshare version.

I tried another node which is called “LigPrep” from Schrodinger and that worked.

Hello @tahami,

There are two questions here - first, I will focus on the Pharmacelera nodes. Pharmacelera is a separate company/extension and has no relation to Schrödinger. If you are trying to connect KNIME to Schrödinger you do not need the Pharmacelera nodes.

Second, if we are only connecting KNIME to Schrödinger, it seems there is a license or version issue. In that regard, I will connect you with @Schroedinger who can assist you further.

Thank you,


Hi @tahami,

The Pharmacelera nodes only work on Linux, this is likely causing this issue.


1 Like

The question about the Schrodinger nodes is discussed offline. Thanks for contacting us via


1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.