Error while running Deep Learning Workflow from Examples


I just downloaded the ‘09_Wide_and_Deep_Learning_on_Census_Dataset’ to my local workspace and deployed my server to test. I’m getting error saying plugins not installed, namely, ‘Keras to Tensorflow Network Convertor’ and ‘JavaScript Scorer (Labs)’ not installed.

I have checked my installed extensions and they look fine. Not sure what’s causing this error:

Appreciate any help !

Mohammed Ayub

Hi Mohammed,

I think you are looking for the Keras integration.
Cheers, gabor

Thanks @aborg

I executed once on my laptop and deleted the old file from WebPortal and redeployed the workflow. It’s giving me an error while running it on web portal.
Below are snapshot of the checks, local run and error.

Keras KNIME Extension 3.6.1:

Successful Local Run:

Web Portal Error:

Let me know if I’m missing anything.

Mohammed Ayub

Hi @mohammedayub,

this sounds like Python a version problem on your server installation. Can you double-check that you’re running with Keras 2.1.x and Tensorflow 1.8?



Hi @christian.dietz
Hope your doing well. I was running older version for Tensorflow (1.5.1) , updated to 1.8.0. Restarted KNIME and redeployed to server. Still gives me the same error (only on web portal, runs fine on local)

I’m running Python 3.5.5 as default.

Hey @mohammedayub,

Likewise! Good seeing you using our new Deep Learning Extension :-). Let’s get this debugged! Can you provide the knime.log output? Maybe this provides more insights. Also, what’s the path to your KNIME tmp directory? Sometimes, on windows, paths become too long.



Hi @christian.dietz
Sorry for my late reply.
I’m guessing your are referring to the KNIME executor log file: D:\KNIME Server 4.7\workflow_repository\runtime\runtime_knime-rmi-50101.metadata\knime\knime.log. (File Attached (372.6 KB))

I found this error in log file:
2018-09-19 09:37:43,306 : DEBUG : DL-Installation-Test-Trigger-org.knime.dl.keras.theano.core.DLKerasTheanoNetwork : DLPythonNetworkLoaderRegistry : : : Installation test for deep learning Python back end ‘org.knime.dl.keras.theano.core.DLKerasTheanoNetwork’ failed: Deep learning Python back end installation tests failed.
Cause: Python library ‘theano’ or one of its dependencies is missing.
Python library ‘keras’ or one of its dependencies is missing.
Further output: Using Theano backend. "

Also, where do I configure the temp directory for Web portal ?

Thanks !
Mohammed Ayub

Hi @mohammedayub,

the warnings you found in the log file shouldn’t be the issue because the integration should then use the TensorFlow backend for which the installation test didn’t fail.

The log you provided contains many runs and different issues but I couldn’t identify any issue that wasn’t solved later. Also I didn’t find the error you get in the web portal. Can you reproduce the problem in it’s one log file (rename the log file such that a new one is created) such that I can identify the real issue?


Hi @bwilhelm

Sorry I had two executor directories.

Replicated the error. here is the correct log file.

deep_learning_knime_log.txt (777.6 KB)

Thanks !

Mohammed Ayub

Just for debugging reasons: does it work if you rename the workflow to something much shorter, e.g. “abc”?

I think Christian is on the right track:

This log entry:

tensorflow.python.framework.errors_impl.NotFoundError: Failed to create a NewWriteableFile: D:\KNIME Server 4.7\workflow_repository\jobs\job_09_Wide_and_Deep_Learning_on_Census_Dataset_for_mayub_6a6d83c0-cdbf-4954-bf94-9a752803f4de\flowContextTmp\tf96964\sm\variables\variables_temp_37d4ac5829d74ac7816046eaf29a42f0/ : The system cannot find the path specified.

suggests that TensorFlow fails to create a new file because its designated path is too long. Windows usually restricts the length of file paths to 260 characters. Depending on your Windows version, you may also be able to increase that maximum.

1 Like

Adding to that: We already fixed the lengthy name of the job in our nightly build.

@christian.dietz - I renamed the file to something shorter like ‘ab’ and re-deployed. It ran successfully without any error. Thanks for that.

Thanks @MarcelW - I will try changing the Windows max File length.

Mohammed Ayub

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.